app-editors/gnome-latex: bump to 3.28.1
authorMart Raudsepp <leio@gentoo.org>
Thu, 4 Apr 2019 10:45:11 +0000 (13:45 +0300)
committerMart Raudsepp <leio@gentoo.org>
Thu, 4 Apr 2019 10:59:27 +0000 (13:59 +0300)
This is the newest we can bump to for now. Newer needs sorting out
of enchant-2 and newer gspell first.

Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
app-editors/gnome-latex/Manifest
app-editors/gnome-latex/gnome-latex-3.28.1.ebuild [new file with mode: 0644]

index 87ee392b60b3cec6c71033a6f22a0711a46392de..6d5a8d9ec348be0f65583f643af0cb090a716b29 100644 (file)
@@ -1,2 +1,3 @@
+DIST gnome-latex-3.28.1.tar.xz 1082708 BLAKE2B 3b0a341278838b37fb1a54f4f746af4fc6ccf4dd37f6b919f53523acfdcbeb6a8974217260db4d8186b8acd3ba782cbc1ddf1dce20735d70d01c88ed3c1fb90f SHA512 fe5c2456839757237d422d0f0629f11a43a8ca5b3cd86ce94b37ee26f68165f111940d5c3c47adba7be05532c413a97a867219c498abec3fd064122516e0c470
 DIST latexila-3.22.1.tar.xz 1111820 BLAKE2B 8a3e375ba048112565f6b074ec62a243fb34890f6e903a2ba2d36f7bb5ede6b0fcb8b488a725752c2edd06b0c71916f13915ebdc26fcf8b6a889523b99141b10 SHA512 7c2d3b95b9547e97c79f5e6384b1f33ccb81e70cea1d26fcc07845f3f391ac54b5931ddcec742f3439ba55e8f9f2a2054935795ab16bee584eb05780a72ba3a9
 DIST latexila-3.24.3.tar.xz 1112940 BLAKE2B 2410276574f02735dde9ce77a9bba257e3732784664b302870957fc3f8603bedddaebed4da3f6da1e1f6fc30e3dc233146b65dbf7589a8776c653018a4129355 SHA512 c7c8996704e68ed136d3d2a04c839faf5497a78ad459411daaabfba38ac883f253325f07a8c126cc4b2f1d553fe08b39f1d6a51d1b6944540dc13142173e4361
diff --git a/app-editors/gnome-latex/gnome-latex-3.28.1.ebuild b/app-editors/gnome-latex/gnome-latex-3.28.1.ebuild
new file mode 100644 (file)
index 0000000..67673e7
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit gnome2
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/GNOME-LaTeX"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+introspection +latexmk rubber"
+
+COMMON_DEPEND="
+       app-text/enchant:0
+       >=app-text/gspell-1.0:0=
+       >=dev-libs/glib-2.56:2
+       >=dev-libs/libgee-0.10:0.8=
+       gnome-base/gsettings-desktop-schemas
+       >=x11-libs/gtk+-3.22:3
+       >=x11-libs/gtksourceview-4.0:4
+       >=gui-libs/tepl-4.0:4
+       x11-libs/gdk-pixbuf:2
+       x11-libs/pango
+       introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+       gnome-base/dconf
+"
+RDEPEND="${COMMON_DEPEND}
+       virtual/latex-base
+       x11-themes/hicolor-icon-theme
+       latexmk? ( dev-tex/latexmk )
+       rubber? ( dev-tex/rubber )
+"
+DEPEND="${COMMON_DEPEND}
+       dev-util/gdbus-codegen
+       dev-util/glib-utils
+       >=dev-util/gtk-doc-am-1.14
+       >=dev-util/intltool-0.50.1
+       dev-util/itstool
+       virtual/pkgconfig
+"
+
+src_configure() {
+       gnome2_src_configure \
+               $(use_enable introspection) \
+               --enable-dconf_migration
+}