dev-ros/bondcpp: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 15:13:45 +0000 (17:13 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 15:13:45 +0000 (17:13 +0200)
Package-Manager: portage-2.2.21

dev-ros/bondcpp/Manifest [new file with mode: 0644]
dev-ros/bondcpp/bondcpp-1.7.16.ebuild [new file with mode: 0644]
dev-ros/bondcpp/bondcpp-9999.ebuild [new file with mode: 0644]
dev-ros/bondcpp/metadata.xml [new file with mode: 0644]

diff --git a/dev-ros/bondcpp/Manifest b/dev-ros/bondcpp/Manifest
new file mode 100644 (file)
index 0000000..0d7a60a
--- /dev/null
@@ -0,0 +1 @@
+DIST bond_core-1.7.16.tar.gz 25327 SHA256 177dc78ef9cf3cd9f48fe5aca4742f504956c71641c75048b7559af0e2aacd53 SHA512 1c35776782edfb7397845fde0ef3fcaac6179f1c55637fd5209303feb1755f13bff85e6cf36a2dd2671c18d5b433cb8e9ede04df923f742e22934b19d044e06e WHIRLPOOL 56fd05d2c6c8f5fb9fa8b47f2da939e16f79f39937febbf588137d5dd411c03f0c30edb3e70b50ed4c6b7c1ce8a0f1cd8c1922038c20495e62a57c80d0958864
diff --git a/dev-ros/bondcpp/bondcpp-1.7.16.ebuild b/dev-ros/bondcpp/bondcpp-1.7.16.ebuild
new file mode 100644 (file)
index 0000000..68f6832
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of bond, a mechanism for checking when another process has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/bond
+       dev-ros/cmake_modules
+       dev-ros/roscpp
+       dev-ros/smclib
+       dev-libs/boost:=
+       sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/bondcpp/bondcpp-9999.ebuild b/dev-ros/bondcpp/bondcpp-9999.ebuild
new file mode 100644 (file)
index 0000000..68f6832
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of bond, a mechanism for checking when another process has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/bond
+       dev-ros/cmake_modules
+       dev-ros/roscpp
+       dev-ros/smclib
+       dev-libs/boost:=
+       sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/bondcpp/metadata.xml b/dev-ros/bondcpp/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>