dev-tex/xmltex: Unpack with /bin/gzip explicitly
authorMatt Turner <mattst88@gentoo.org>
Fri, 17 Apr 2020 00:41:09 +0000 (17:41 -0700)
committerMatt Turner <mattst88@gentoo.org>
Fri, 17 Apr 2020 00:43:39 +0000 (17:43 -0700)
... in order to work around an incompatibility in app-arch/pigz. It
appears that xmltex's tarball has trailing junk at the end of the file,
and it appears to be a completed project, so no new releases are
forthcoming.

Closes: https://bugs.gentoo.org/645438
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-tex/xmltex/xmltex-1.9-r3.ebuild

index 177068ab92580fc5ddcb16fe49559b098a761974..5b9a6f94c672d64363c6c18f7905729fb3894eff 100644 (file)
@@ -22,6 +22,11 @@ DEPEND="virtual/latex-base"
 
 RDEPEND="${DEPEND}"
 
+src_unpack() {
+       # Bug 645438
+       tar -I /bin/gzip -xf "${DISTDIR}"/${P}.tar.gz || die
+}
+
 src_compile() {
        fmt_call="$(has_version '>=app-text/texlive-core-2019' \
          && echo "fmtutil-user" || echo "fmtutil")"