dev-python/terminaltables: EAPI 7, tests, py3.7
authorMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 12:13:37 +0000 (14:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 12:16:46 +0000 (14:16 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/terminaltables/terminaltables-3.1.0.ebuild

index 7c1b9f0d30de4b27e6465e9c765aa19f06f1f87b..851902172a4327a3ab6d85d3f7e8db08f2c681d5 100644 (file)
@@ -1,18 +1,29 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
 inherit distutils-r1
 
 DESCRIPTION="Generate simple tables in terminals from a nested list of strings"
-
 HOMEPAGE="https://robpol86.github.io/terminaltables"
 SRC_URI="https://github.com/Robpol86/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/colorama[${PYTHON_USEDEP}]
+               dev-python/colorclass[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/termcolor[${PYTHON_USEDEP}]
+       )"
+
+python_test() {
+       pytest -vv || die "Tests fail with ${EPYTHON}"
+}