media-sound/qsynth: version bump to 0.5.3, fix QA, EAPI 7
authorNikos Chantziaras <realnc@gmail.com>
Wed, 7 Nov 2018 22:09:15 +0000 (00:09 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 9 Nov 2018 00:42:57 +0000 (01:42 +0100)
Closes: https://bugs.gentoo.org/670636
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Nikos Chantziaras <realnc@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/10358
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-sound/qsynth/Manifest
media-sound/qsynth/qsynth-0.5.3.ebuild [new file with mode: 0644]

index 8b206d6e9877f67b9e4b3bef5831a193e75e0a16..92c3fefcb871e82fd911c389526d6b9d4ae9f031 100644 (file)
@@ -1 +1,2 @@
 DIST qsynth-0.5.0.tar.gz 260537 BLAKE2B def589a1cfb76517fa34811fe75a8379043d7e0f9fc661dd456b49414042662c3a3b8f57e2d0de5fae99cbdb60062b12d9b73b93032115648b9a21921766fbeb SHA512 3c7026edfef3115fae8e2167bb961f5e32d886c8d75b3534a3f110d921264cd270953145a4737f9d6660c55fccce81d7306ec0ce4064df6e7226598b52399298
+DIST qsynth-0.5.3.tar.gz 269252 BLAKE2B c496063ba33bc78a65d63151871e841f9d3938fe03049655da3c124fd495c592f9c726c479062c3fb2d1561e4dee3284d12b04e04a51ba06e20d297b6e84ac0f SHA512 15632274e5822f5e1a49bd332c5d8b7e59a54800ad32510f425f06b4557e474d5479bd531b45fc43af20535017a656fbd9469d318940931912a56ea1856dc117
diff --git a/media-sound/qsynth/qsynth-0.5.3.ebuild b/media-sound/qsynth/qsynth-0.5.3.ebuild
new file mode 100644 (file)
index 0000000..1abb520
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic qmake-utils
+
+DESCRIPTION="A Qt application to control FluidSynth"
+HOMEPAGE="http://qsynth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="alsa debug jack pulseaudio"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       media-sound/fluidsynth[jack?,alsa?,pulseaudio?]
+       x11-libs/libX11"
+DEPEND="${RDEPEND}
+       dev-qt/linguist-tools:5
+"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.4.0-qt5-tagging.patch" )
+
+src_configure() {
+       append-cxxflags -std=c++11
+       sed -e "/@gzip.*mandir)\/man1/d" -i Makefile.in || die
+       econf \
+               $(use_enable debug) \
+               --with-qt5=$(qt5_get_bindir)/..
+
+       eqmake5 ${PN}.pro -o ${PN}.mak
+}
+
+src_install () {
+       emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+       einstalldocs
+
+       # The desktop file is invalid, and we also change the command
+       # depending on useflags
+       rm "${ED}/usr/share/applications/qsynth.desktop" || die
+
+       local cmd
+       if use jack; then
+               cmd="qsynth"
+       elif use pulseaudio; then
+               cmd="qsynth -a pulseaudio"
+       elif use alsa; then
+               cmd="qsynth -a alsa"
+       else
+               cmd="qsynth -a oss"
+       fi
+
+       make_desktop_entry "${cmd}" Qsynth qsynth
+}