net-analyzer/sarg: Version 2.4.0_pre3
authorJeroen Roovers <jer@gentoo.org>
Thu, 26 Dec 2019 12:11:25 +0000 (13:11 +0100)
committerJeroen Roovers <jer@gentoo.org>
Thu, 26 Dec 2019 12:11:40 +0000 (13:11 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/sarg/Manifest
net-analyzer/sarg/files/sarg-2.4.0-config.patch [new file with mode: 0644]
net-analyzer/sarg/files/sarg-2.4.0-configure.patch [new file with mode: 0644]
net-analyzer/sarg/files/sarg-2.4.0-fabs.patch [new file with mode: 0644]
net-analyzer/sarg/files/sarg-2.4.0-format.patch [new file with mode: 0644]
net-analyzer/sarg/metadata.xml
net-analyzer/sarg/sarg-2.4.0_pre3.ebuild [new file with mode: 0644]

index d1303f0db429b15c0c911111686a1f9e8872c330..50e335d06b7c8480894cd8e9804979f44aa43a97 100644 (file)
@@ -1 +1,2 @@
 DIST sarg-2.3.11.tar.gz 1346884 BLAKE2B f1ba5e5d3531b611cca1e18444b24772d5f6fb31622d3702ce34bf7e5208b7ff04000ed80c984ff103f785dd9b7015f56403b8389100bbd02cdbf936c8343be9 SHA512 a5bf5c0f696a9d58d9dd1d631d2b458e7a48f597e7a084b032b2feb6185440b08babe7ffaaefc04676f0dbc11301084d1896b6246a7e79a10acdbd7aa7882ff6
+DIST sarg-2.4.0-pre3.tar.gz 1364547 BLAKE2B 94729294de60ded125abd346d38833c64b3f0b320b0e07fc8153e287ce84b09ff83259fe2189afa087a46e6617d47628c162e3bda209563e3f7618d71ffd0cd5 SHA512 136313e36a8107f1ba84f7653aa3a0972beea05b89d77d8bd02a564c62881696f87bd2ed6cd0069624fe2ed013042cd604932220c8476d62702d27e68e8fd655
diff --git a/net-analyzer/sarg/files/sarg-2.4.0-config.patch b/net-analyzer/sarg/files/sarg-2.4.0-config.patch
new file mode 100644 (file)
index 0000000..1168f98
--- /dev/null
@@ -0,0 +1,81 @@
+--- a/log.c
++++ b/log.c
+@@ -151,7 +151,7 @@
+       strcpy(FontSize,"9px");
+       strcpy(TempDir,"/tmp");
+       TempDirPath[0] = '\0';
+-      strcpy(OutputDir,"/var/www/html/squid-reports");
++      strcpy(OutputDir,"/var/www/localhost/htdocs/squid-reports");
+       AnonymousOutputFiles=false;
+       Ip2Name=false;
+       DateFormat='u';
+--- a/htaccess
++++ b/htaccess
+@@ -1,4 +1,4 @@
+-AuthUserFile /usr/local/sarg/passwd
++AuthUserFile /etc/sarg/passwd
+ AuthName "SARG, Squid Analysis Report Generator"
+ AuthType Basic
+ <Limit GET POST>
+--- a/sarg.conf
++++ b/sarg.conf
+@@ -17,7 +17,7 @@
+ #       If some files are passed on the command line with "sarg -l file" or
+ #       "sarg file", the files listed here are ignored.
+ #
+-#access_log /usr/local/squid/var/logs/access.log
++#access_log /var/log/squid/access.log
+ # TAG: graphs yes|no
+ #     Use graphics where is possible.
+@@ -147,7 +147,7 @@
+ #       The reports will be saved in that directory
+ #       sarg -o dir
+ #
+-#output_dir /var/www/html/squid-reports
++#output_dir /var/www/localhost/htdocs/squid-reports
+ # TAG:  anonymous_output_files yes/no
+ #       Use anonymous file and directory names in the report. If it is set to
+@@ -632,7 +632,7 @@
+ #      Generate reports from SquidGuard logs.
+ #      Use 'none' to disable.
+ #      You can use sarg -L filename to use an alternate squidGuard log.
+-#      squidguard_conf /usr/local/squidGuard/squidGuard.conf
++#      squidguard_conf /etc/squidGuard/squidGuard.conf
+ #
+ #squidguard_conf none
+--- a/user_limit_block
++++ b/user_limit_block
+@@ -24,8 +24,8 @@
+ #
+ #
+-conf="/usr/local/sarg/sarg.conf"
+-squid_password_file="/usr/local/squid/etc/passwd"
++conf="/etc/sarg/sarg.conf"
++squid_password_file="/etc/squid/passwd"
+ tmp="/tmp/sarg_limit.$$"
+ limit_file=`grep "per_user_limit" $conf|grep -v "#"|awk '{print $2}'`
+--- a/sarg-php/config.php.inc
++++ b/sarg-php/config.php.inc
+@@ -1,13 +1,13 @@
+ <?php
+ // Change to squidGuard and sarg config file paths
+-$SargConf = "/usr/local/sarg/sarg.conf";
+-$squidGuardConf = "/usr/local/squidGuard/squidGuard.conf";
++$SargConf = "/etc/sarg/sarg.conf";
++$squidGuardConf = "/etc/squidGuard/squidGuard.conf";
+ // File where URL to block will be appended
+-$DefaultSquidBlock = "/usr/local/squid/etc/block.txt";
++$DefaultSquidBlock = "/etc/squid/etc/block.txt";
+ // Choose the locale you want to use to display messages (it must exist on your system)
+-$language = "fr_BE.utf-8";
++$language = "POSIX";
+ ?>
diff --git a/net-analyzer/sarg/files/sarg-2.4.0-configure.patch b/net-analyzer/sarg/files/sarg-2.4.0-configure.patch
new file mode 100644 (file)
index 0000000..7ca44a6
--- /dev/null
@@ -0,0 +1,43 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -35,6 +35,11 @@
+ dnl C99 support is required to define LLONG_MAX (at least on CentOS 5.7)
+ AC_PROG_CC_C99
++dnl mkdir_p / MKDIR_P
++AC_PROG_MKDIR_P
++mkdir_p="$MKDIR_P"
++AC_SUBST(mkdir_p)
++
+ # Report more warnings to improve code quality.
+ CFLAGS="${CFLAGS} -Wall"
+@@ -50,23 +55,23 @@
+ # Don't compare signs as it is a mess
+ CFLAGS="${CFLAGS} -Wno-sign-compare"
+-AC_MSG_CHECKING([for implicit-function-declaration error flag in $CC])
++AC_MSG_CHECKING([for implicit-function-declaration warning flag in $CC])
+ saved_CFLAGS="${CFLAGS}"
+-CFLAGS="${CFLAGS} -Werror=implicit-function-declaration"
++CFLAGS="${CFLAGS} -Wimplicit-function-declaration"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_implicit_function_declaration="yes"],[have_implicit_function_declaration="no"])
+ AC_MSG_RESULT($have_implicit_function_declaration)
+ AS_IF([test "$have_implicit_function_declaration" = "no"],[CFLAGS="${saved_CFLAGS}"])
+-AC_MSG_CHECKING([for format error flag in $CC])
++AC_MSG_CHECKING([for format warning flag in $CC])
+ saved_CFLAGS="${CFLAGS}"
+-CFLAGS="${CFLAGS} -Werror=format"
++CFLAGS="${CFLAGS} -Wformat"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_error_format="yes"],[have_error_format="no"])
+ AC_MSG_RESULT($have_error_format)
+ AS_IF([test "$have_error_format" = "no"],[CFLAGS="${saved_CFLAGS}"])
+ case "$host" in
+    *-solaris*)
+-   LDFLAGS="${LDFLAGS} -lsocket -lnsl"
++   LIBS="${LIBS} -lsocket -lnsl"
+    CFLAGS="-DSOLARIS ${CFLAGS}"
+    ;;
+ esac
diff --git a/net-analyzer/sarg/files/sarg-2.4.0-fabs.patch b/net-analyzer/sarg/files/sarg-2.4.0-fabs.patch
new file mode 100644 (file)
index 0000000..e9b73d8
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/btree_cache.c
++++ b/btree_cache.c
+@@ -268,7 +268,7 @@
+ static struct bt *get_disbalanced_node(struct bt *node)
+ {
+       struct bt *rdn;
+-      if (fabs(node->balanceinfo) > 1)
++      if (abs(node->balanceinfo) > 1)
+               return node;
+       if (node->left)
+       {
diff --git a/net-analyzer/sarg/files/sarg-2.4.0-format.patch b/net-analyzer/sarg/files/sarg-2.4.0-format.patch
new file mode 100644 (file)
index 0000000..686f659
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/userinfo.c
++++ b/userinfo.c
+@@ -78,7 +78,7 @@
+       int skip;
+       int flen;
+       int count, clen;
+-      char cstr[9];
++      char cstr[10];
+       char filename[MAX_USER_FNAME_LEN];
+       if (!UserStrings) {
+--- a/index.c
++++ b/index.c
+@@ -535,7 +535,7 @@
+       struct dirent *direntp;
+       char yearindex[MAXLEN];
+       char yeardir[MAXLEN];
+-      char yearnum[10];
++      char yearnum[15];
+       int yearsort[150];
+       int nyears;
+       int year;
index deaa23376cb03c11c2b19b18146b81dc1943c1cd..774ea9db6563338fdbdc7974262bf04e1b855dfc 100644 (file)
@@ -1,19 +1,18 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-  <maintainer type="project">
-    <email>netmon@gentoo.org</email>
-    <name>Gentoo network monitoring and analysis project</name>
-  </maintainer>
-  <longdescription>Sarg - Squid Analysis Report Generator is a tool that allow
- you to view "where" your users are going to on the Internet. Sarg provides many
- informations about Squid users activities: times, bytes, sites, etc...
- </longdescription>
-  <use>
-    <flag name="pcre">Enable support for regular expressions in the hostalias file through <pkg>dev-libs/libpcre</pkg></flag>
-    <flag name="gd">Enable support for graphs in reports through <pkg>media-libs/gd</pkg></flag>
-  </use>
-  <upstream>
-    <remote-id type="sourceforge">sarg</remote-id>
-  </upstream>
+<maintainer type="project">
+<email>netmon@gentoo.org</email>
+<name>Gentoo network monitoring and analysis project</name>
+</maintainer>
+<longdescription>Squid Analysis Report Generator is a tool that allow you to view where your users are going to on the Internet. Sarg provides many informations about Squid users activities: times, bytes, sites, etc...</longdescription>
+<use>
+<flag name="doublecheck">Make sarg double check the data it manipulates and output a warning if an error is found</flag>
+<flag name="gd">Enable support for graphs in reports through <pkg>media-libs/gd</pkg></flag>
+<flag name="glob">Disable to ignore wildcards in file names</flag>
+<flag name="pcre">Enable support for regular expressions in the hostalias file through <pkg>dev-libs/libpcre</pkg></flag>
+</use>
+<upstream>
+<remote-id type="sourceforge">sarg</remote-id>
+</upstream>
 </pkgmetadata>
diff --git a/net-analyzer/sarg/sarg-2.4.0_pre3.ebuild b/net-analyzer/sarg/sarg-2.4.0_pre3.ebuild
new file mode 100644 (file)
index 0000000..992488f
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Squid Analysis Report Generator"
+HOMEPAGE="https://sourceforge.net/projects/sarg/"
+SRC_URI="mirror://sourceforge/${PN}/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="bzip2 doublecheck +gd +glob ldap lzma pcre zlib"
+
+RDEPEND="
+       bzip2? ( app-arch/bzip2 )
+       gd? ( media-libs/gd[png,truetype] )
+       ldap? ( net-nds/openldap )
+       lzma? ( app-arch/xz-utils )
+       pcre? ( dev-libs/libpcre )
+       zlib? ( sys-libs/zlib )
+"
+DEPEND="
+       ${RDEPEND}
+"
+DOCS=( BETA-TESTERS CONTRIBUTORS DONATIONS README ChangeLog htaccess )
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.4.0-config.patch
+       "${FILESDIR}"/${PN}-2.4.0-configure.patch
+       "${FILESDIR}"/${PN}-2.4.0-fabs.patch
+       "${FILESDIR}"/${PN}-2.4.0-format.patch
+)
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+       default
+
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_enable doublecheck) \
+               $(use_with bzip2 bzlib) \
+               $(use_with gd) \
+               $(use_with glob) \
+               $(use_with ldap) \
+               $(use_with lzma liblzma) \
+               $(use_with pcre) \
+               $(use_with zlib) \
+               --sysconfdir="${EPREFIX}/etc/sarg/"
+}
+
+src_install() {
+       default
+
+       dodoc documentation/*
+}