dev-vcs/tig: Use slot operators for ncurses; Version Bump
authorJustin Lecher <jlec@gentoo.org>
Sun, 16 Aug 2015 14:13:47 +0000 (16:13 +0200)
committerJustin Lecher <jlec@gentoo.org>
Sun, 16 Aug 2015 14:20:54 +0000 (16:20 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-vcs/tig/Manifest
dev-vcs/tig/tig-2.0.3.ebuild
dev-vcs/tig/tig-2.1.1.ebuild [new file with mode: 0644]
dev-vcs/tig/tig-2.1.ebuild

index ca4a5d525dfd730559386511c4ecf91c933a195a..157c19c33a0f1fcf38f96fc36fad552b92d65511 100644 (file)
@@ -1,2 +1,3 @@
 DIST tig-2.0.3.tar.gz 605513 SHA256 faac0fd80cb771cf34ae0aa9b2fedba1cc0f8aa70731d400661660c8d48f96c4 SHA512 0d16c4ec68d7b846b8cb990756ff683584eaf7eea89f9853d3803c86ef7544e2b80e1376a0e441082d7d23a2496fb7bcf8b5d987fe026b3d85e777064351fa15 WHIRLPOOL 6e63b1622aa593e7ee30db5356f438ef536f428a30f917b1bce43204a4c27b7b21b3268b5c97fde5c6518b4a1fd81a85f2168138e94aab7b8673176c01b0265f
+DIST tig-2.1.1.tar.gz 641710 SHA256 50c5179fd564b829b6b2cec087e66f10cf8799601de19350df0772ae77e4852f SHA512 be55ece813e1af938e3c4d805d4f034e78f75c1fcda7f4b5bc02de8b228d6d76b9f4921f6dc079485b8c13a3acc5ea2d146a0c437d28add45d50137ae6545f10 WHIRLPOOL 869012b9e5d47eaa24d7939202819bcf85c44ed4d2de742d7770d8610f3e86dfae43588f626de2785f10e78293c21151272b81b0f196163844ea8b76cce5d01c
 DIST tig-2.1.tar.gz 635114 SHA256 306287f684f57563a53abf1cf46149e0d30c6b500fbc0c39e9bc059506373cb0 SHA512 d21d263b62675721467aca35cf2f7fbe41e0042ac295516bd67e348039030df53de30f5dea3059c4b13188e450921972920c014f0381729826c727dcdd7f6804 WHIRLPOOL 9a5ea63fd985764c0d06660bc58d3ffe11bb9242ab92ec8dc7d638e1e5f5693e342577fc1bceb7e899386f96baaa467506bfb9a3fc5ff52231c24f317c9cb68d
index 3547f5b306775ed09fa270392be1bb6efd54b10b..ee4a698da74262cbbec002d9676df29150c2793f 100644 (file)
@@ -6,7 +6,7 @@ EAPI=5
 
 inherit bash-completion-r1 toolchain-funcs
 
-DESCRIPTION="Tig: text mode interface for git"
+DESCRIPTION="text mode interface for git"
 HOMEPAGE="http://jonas.nitro.dk/tig/"
 SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
 
@@ -15,8 +15,9 @@ SLOT="0"
 KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
 IUSE="unicode"
 
-DEPEND="sys-libs/ncurses[unicode?]
-       sys-libs/readline:0"
+DEPEND="
+       sys-libs/ncurses:5=[unicode?]
+       sys-libs/readline:0="
 RDEPEND="${DEPEND}
        dev-vcs/git"
 
diff --git a/dev-vcs/tig/tig-2.1.1.ebuild b/dev-vcs/tig/tig-2.1.1.ebuild
new file mode 100644 (file)
index 0000000..3a943bb
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="unicode"
+
+DEPEND="
+       sys-libs/ncurses:5=[unicode?]
+       sys-libs/readline:0"
+RDEPEND="${DEPEND}
+       dev-vcs/git"
+
+src_prepare() {
+       # pre-generated manpages are in the root directory
+       sed -i '/^MANDOC/s#doc/##g' Makefile || die
+}
+
+src_configure() {
+       econf $(use_with unicode ncursesw)
+}
+
+src_compile() {
+       emake V=1
+}
+
+src_test() {
+       # workaround parallel test failures
+       emake -j1 test
+}
+
+src_install() {
+       emake DESTDIR="${D}" install install-doc-man
+       dohtml manual.html README.html NEWS.html
+       newbashcomp contrib/tig-completion.bash ${PN}
+
+       docinto examples
+       dodoc contrib/*.tigrc
+}
index 7c5983a2f38b430b6d40abff45eab97c9b5ab575..236f7668c5f2c4389996ed44de405f1896bb8398 100644 (file)
@@ -6,7 +6,7 @@ EAPI=5
 
 inherit bash-completion-r1 toolchain-funcs
 
-DESCRIPTION="Tig: text mode interface for git"
+DESCRIPTION="text mode interface for git"
 HOMEPAGE="http://jonas.nitro.dk/tig/"
 SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
 
@@ -15,8 +15,8 @@ SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
 IUSE="unicode"
 
-DEPEND="sys-libs/ncurses[unicode?]
-       sys-libs/readline:0"
+DEPEND="sys-libs/ncurses:5=[unicode?]
+       sys-libs/readline:0="
 RDEPEND="${DEPEND}
        dev-vcs/git"