net-analyzer/packit: Add live ebuild
authorJeroen Roovers <jer@gentoo.org>
Mon, 27 Jan 2020 00:19:33 +0000 (01:19 +0100)
committerJeroen Roovers <jer@gentoo.org>
Mon, 27 Jan 2020 00:19:41 +0000 (01:19 +0100)
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/packit/packit-9999.ebuild [new file with mode: 0644]

diff --git a/net-analyzer/packit/packit-9999.ebuild b/net-analyzer/packit/packit-9999.ebuild
new file mode 100644 (file)
index 0000000..d58eaf3
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools git-r3
+
+DESCRIPTION="network packet generator and capture tool"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/packit"
+EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/packit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="
+       net-libs/libnet:1.1
+       net-libs/libpcap
+"
+RDEPEND="${DEPEND}"
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.0-noopt.patch
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_install() {
+       default
+       dodoc docs/*
+}