sys-apps/hwloc: bump 1.11.10
authorJustin Bronder <jsbronder@gentoo.org>
Mon, 26 Mar 2018 16:53:49 +0000 (12:53 -0400)
committerJustin Bronder <jsbronder@gentoo.org>
Mon, 26 Mar 2018 16:53:49 +0000 (12:53 -0400)
Bump for https://bugs.gentoo.org/650882
Also kicking the can on https://bugs.gentoo.org/611678

Package-Manager: Portage-2.3.24, Repoman-2.3.6

sys-apps/hwloc/Manifest
sys-apps/hwloc/hwloc-1.11.10.ebuild [new file with mode: 0644]

index 3a2f277691a852dcc19d23e98881590e43034a43..9237c888db02508d85c68ab94b14c059ae17b259 100644 (file)
@@ -1,2 +1,3 @@
+DIST hwloc-1.11.10.tar.bz2 4102431 BLAKE2B 4caec6f1c1a5f0b571854127cc6fd808e778b3b2bcf7ded7edfe99100ac4ccc05c893f3df0a56119234510aa5256e5da84cfa15dddb7d15e49eca2936baa7f41 SHA512 9e2cf5cc43f8c21cfd0bf09a58fda09ba832908eca5a211d164eb106f090609b6351bc934e572200530284fbfc5c460db29a49ec7974dbd298d757ed8aaf32b3
 DIST hwloc-1.11.2.tar.bz2 4019136 BLAKE2B 29a959c48b3be347b5816333c3f9948ddafc6c4882d7c646c956ae08d72827dd4cef22da7842a034e3131e0044f9528573c6dfceb373869c326890f23651d967 SHA512 aa54b6389c303470a00dbbb3ae5f688244d0f1e0d84e661b739933ff9d86928869f2f3be04fe621cdf06c206defcd4ea1c9e8b72696f7cada9bb3243c3feba68
 DIST hwloc-1.11.7.tar.bz2 4187754 BLAKE2B 9d55c35ee328eddbdb9364f4330d157eeefb53fd01b3d0cba23423515302ab0f43aac6c6aaec3a96277411883e3806888aa1c55d2312e102d00302305279f044 SHA512 f3afd123f917d07fe987b8a16dba9f1aa9a9112fc4bdc806417c942b5fbd3b7f31067550048258814b4ba08d4ac7bd45c1fd477457d817bf9453735e0b82f04e
diff --git a/sys-apps/hwloc/hwloc-1.11.10.ebuild b/sys-apps/hwloc/hwloc-1.11.10.ebuild
new file mode 100644 (file)
index 0000000..a0470df
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools cuda flag-o-matic versionator multilib-minimal
+
+MY_PV=v$(get_version_component_range 1-2)
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="cairo cuda debug gl +numa +pci plugins svg static-libs xml X"
+
+# opencl support dropped with x11-drivers/ati-drivers being removed (#582406).
+# Anyone with hardware is welcome to step up and help test to get it re-added.
+
+# dev-util/nvidia-cuda-toolkit is always multilib
+
+RDEPEND=">=sys-libs/ncurses-5.9-r3:0[${MULTILIB_USEDEP}]
+       cairo? ( >=x11-libs/cairo-1.12.14-r4[X?,svg?,${MULTILIB_USEDEP}] )
+       cuda? ( >=dev-util/nvidia-cuda-toolkit-6.5.19-r1 )
+       gl? ( || ( x11-drivers/nvidia-drivers[static-libs,tools] media-video/nvidia-settings ) )
+       pci? (
+               >=sys-apps/pciutils-3.3.0-r2[${MULTILIB_USEDEP}]
+               >=x11-libs/libpciaccess-0.13.1-r1[${MULTILIB_USEDEP}]
+       )
+       plugins? ( dev-libs/libltdl:0[${MULTILIB_USEDEP}] )
+       numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )
+       xml? ( >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${PN}-1.8.1-gl.patch" )
+DOCS=( AUTHORS NEWS README VERSION )
+
+src_prepare() {
+       default
+       eautoreconf
+
+       if use cuda ; then
+               append-cflags -I"${EPREFIX}"/opt/cuda/include
+               append-cppflags -I"${EPREFIX}"/opt/cuda/include
+       fi
+}
+
+multilib_src_configure() {
+       export HWLOC_PKG_CONFIG=$(tc-getPKG_CONFIG) #393467
+
+       if use cuda ; then
+               local -x LDFLAGS="${LDFLAGS}"
+               append-ldflags -L"${EPREFIX}"/opt/cuda/$(get_libdir)
+       fi
+
+       ECONF_SOURCE=${S} econf \
+               $(use_enable static-libs static) \
+               $(use_enable cairo) \
+               $(multilib_native_use_enable cuda) \
+               $(use_enable debug) \
+               $(multilib_native_use_enable gl) \
+               $(use_enable pci) \
+               $(use_enable plugins) \
+               $(use_enable numa libnuma) \
+               $(use_enable xml libxml2) \
+               $(use_with X x)
+}