mail-filter/rspamd: fix hyperscan support on i386
authorPetr Vaněk <arkamar@atlas.cz>
Tue, 4 Feb 2020 18:52:38 +0000 (19:52 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 24 Feb 2020 05:19:45 +0000 (07:19 +0200)
The patch is taken from upstream.
https://github.com/rspamd/rspamd/commit/92e62855a64d1f7f0e52720399f8aa31bdcb0983

Closes: https://bugs.gentoo.org/703004
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Petr Vaněk <arkamar@atlas.cz>
Closes: https://github.com/gentoo/gentoo/pull/14572
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
mail-filter/rspamd/files/rspamd-2.2-i386-hyperscan.patch [new file with mode: 0644]
mail-filter/rspamd/rspamd-2.2.ebuild

diff --git a/mail-filter/rspamd/files/rspamd-2.2-i386-hyperscan.patch b/mail-filter/rspamd/files/rspamd-2.2-i386-hyperscan.patch
new file mode 100644 (file)
index 0000000..578d3da
--- /dev/null
@@ -0,0 +1,15 @@
+diff --git a/cmake/Hyperscan.cmake b/cmake/Hyperscan.cmake
+index 3dd774511..b8f83a3bb 100644
+--- a/cmake/Hyperscan.cmake
++++ b/cmake/Hyperscan.cmake
+@@ -1,8 +1,8 @@
+ option (ENABLE_HYPERSCAN    "Enable hyperscan for fast regexp processing [default: OFF]" OFF)
+ if (ENABLE_HYPERSCAN MATCHES "ON")
+-    if (NOT "${ARCH}" STREQUAL "x86_64")
+-        MESSAGE(FATAL_ERROR "Hyperscan is supported only on x86_64 architecture")
++    if (NOT ("${ARCH}" STREQUAL "x86_64" OR "${ARCH}" STREQUAL "i386"))
++        MESSAGE(FATAL_ERROR "Hyperscan is supported only on x86_64/i386 architectures")
+     endif ()
+     ProcessPackage (HYPERSCAN LIBRARY hs INCLUDE hs.h INCLUDE_SUFFIXES
+             hs include/hs
index 3f29e90b90ed75edc794591a2d10292e848a548a..3b7e3129381449ad8b291996452d8e56ca74eaed 100644 (file)
@@ -41,6 +41,8 @@ RDEPEND="
        !pcre2? ( dev-libs/libpcre[jit=] )"
 DEPEND="${RDEPEND}"
 
+PATCHES=( "${FILESDIR}/${P}-i386-hyperscan.patch" )
+
 src_prepare() {
        cmake_src_prepare