dev-python/nodeenv: EAPI 7 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 7 Apr 2019 19:38:40 +0000 (21:38 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 7 Apr 2019 19:46:32 +0000 (21:46 +0200)
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-python/nodeenv/nodeenv-1.1.3-r1.ebuild [new file with mode: 0644]
dev-python/nodeenv/nodeenv-1.1.3.ebuild

diff --git a/dev-python/nodeenv/nodeenv-1.1.3-r1.ebuild b/dev-python/nodeenv/nodeenv-1.1.3-r1.ebuild
new file mode 100644 (file)
index 0000000..2b42bf6
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Node.js virtual environment builder"
+HOMEPAGE="https://github.com/ekalinin/nodeenv"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
index 2b8ede3a5370cd4819f7fa9587547b069a41a2e8..2b42bf6059b3ef1b236d049553cc0374cea8a836 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )