net-im/zoom: Version bump to 3.5.385850.0413.
authorUlrich Müller <ulm@gentoo.org>
Thu, 16 Apr 2020 12:08:18 +0000 (14:08 +0200)
committerUlrich Müller <ulm@gentoo.org>
Thu, 16 Apr 2020 12:09:33 +0000 (14:09 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
net-im/zoom/Manifest
net-im/zoom/zoom-3.5.385850.0413.ebuild [new file with mode: 0644]

index e4ff59709eeabea42862ad7053d114e0b51f04f7..fb195c442a4e4e9843a3aa02f3014214184d49a8 100644 (file)
@@ -1,2 +1,4 @@
 DIST zoom-3.5.383291.0407_i686.tar.xz 48489396 BLAKE2B cfce6356e1f2cea29f9330e18402b7872f93f5fdf4c136f6b40060a2440536b3656ce7fdb28db9721f92f2f462ff4a99d6efb82d4f08bf58ef1a3425dd015665 SHA512 92b6db2bdf6531a876a93069654448a77fa25e645d669df7144d8a8514d63ef9336cef9bfbd9bbaf7f1ce001b26ca7bdb39b19b7549c2b193ee0292f0522e47c
 DIST zoom-3.5.383291.0407_x86_64.tar.xz 72618832 BLAKE2B e9fa38fae525688f8d9f14a0c2bfe04201edfe2719d075caf9d9de0a2454010b68a6d1df0cd480152641f5763caff7aab1427fee268e3c8239797c792551b709 SHA512 531ce43fdeb4c4df50a85e8a28a90f25d9df7c97b87014fef1e9c94836abbc4d6e76f081b2418c6e538052a2f69e052e0a1ebb9bb0dc33cffffc683bb5b2aef4
+DIST zoom-3.5.385850.0413_i686.tar.xz 48715128 BLAKE2B 470bb0ca4479ab81e658a4e1820c4a857b34a929e677ff5fc6b10dcdd12017586d9ea2141d55fe0346fc71ad9cffe5c10eb013dc48c89a3bbf5560143a435f67 SHA512 8aaba240a72101868627dbb64c1027ca6da3c014481b5b7900557c99671baa44af22747408296bee128164b2de5c5b516ae0fb3ffab5ab555ed072056cfb3a99
+DIST zoom-3.5.385850.0413_x86_64.tar.xz 72960852 BLAKE2B d843254eae3aa5047516dcd3d865b77c61e052dac40cf6bfbe1bac7e6c0ce65a9bd6be1f647c5de49bdcb279300577f78358c4ffdedb8e77543fee89a13cc076 SHA512 42e6a2a302c917ac6908827f3ea32cd488633580b68cf04a08e7c43a56f31cbb50427d1835dbec609d2bc5aa10b0ad9ab973febf82bc1a04e61a4fbb1c6f8f8a
diff --git a/net-im/zoom/zoom-3.5.385850.0413.ebuild b/net-im/zoom/zoom-3.5.385850.0413.ebuild
new file mode 100644 (file)
index 0000000..3dccb75
--- /dev/null
@@ -0,0 +1,108 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+DESCRIPTION="Video conferencing and web conferencing service"
+HOMEPAGE="https://zoom.us/"
+SRC_URI="amd64? ( https://zoom.us/client/${PV}/${PN}_x86_64.tar.xz -> ${P}_x86_64.tar.xz )
+       x86? ( https://zoom.us/client/${PV}/${PN}_i686.tar.xz -> ${P}_i686.tar.xz )"
+S="${WORKDIR}/${PN}"
+
+LICENSE="all-rights-reserved Apache-2.0" # Apache-2.0 for icon
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="bundled-libjpeg-turbo pulseaudio"
+RESTRICT="mirror bindist strip"
+
+RDEPEND="!games-engines/zoom
+       dev-libs/glib:2
+       dev-libs/icu
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtdiag:5
+       dev-qt/qtgraphicaleffects:5
+       dev-qt/qtgui:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtquickcontrols:5[widgets]
+       dev-qt/qtscript:5
+       dev-qt/qtsvg:5
+       dev-qt/qtwidgets:5
+       media-sound/mpg123
+       sys-apps/dbus
+       sys-apps/util-linux
+       virtual/opengl
+       x11-libs/libX11
+       x11-libs/libxcb
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXtst
+       x11-libs/xcb-util-image
+       x11-libs/xcb-util-keysyms
+       amd64? (
+               dev-qt/qtdeclarative:5[widgets]
+               dev-qt/qtpositioning:5
+               dev-qt/qtprintsupport:5
+               dev-qt/qtwebchannel:5
+               dev-qt/qtwebengine:5[widgets]
+       )
+       x86? (
+               dev-qt/qtdeclarative:5
+               dev-qt/qtwebkit:5
+       )
+       !bundled-libjpeg-turbo? ( media-libs/libjpeg-turbo )
+       pulseaudio? ( media-sound/pulseaudio )
+       !pulseaudio? ( media-libs/alsa-lib )"
+
+BDEPEND="!pulseaudio? ( dev-util/bbe )"
+
+QA_PREBUILT="opt/zoom/*"
+
+src_prepare() {
+       default
+       if ! use pulseaudio; then
+               # For some strange reason, zoom cannot use any ALSA sound devices if
+               # it finds libpulse. This causes breakage if media-sound/apulse[sdk]
+               # is installed. So, force zoom to ignore libpulse.
+               bbe -e 's/libpulse.so/IgNoRePuLsE/' zoom >zoom.tmp || die
+               mv zoom.tmp zoom || die
+       fi
+}
+
+src_install() {
+       insinto /opt/zoom
+       exeinto /opt/zoom
+       doins -r json sip timezones translations
+       doins *.pcm *.pem *.sh Embedded.properties version.txt
+       use amd64 && doins icudtl.dat
+       doexe zoom{,.sh,linux} zopen ZoomLauncher
+       dosym {"../../usr/$(get_libdir)",/opt/zoom}/libmpg123.so
+
+       if use bundled-libjpeg-turbo; then
+               doexe libturbojpeg.so.0.1.0
+               dosym libturbojpeg.so.0.1.0 /opt/zoom/libturbojpeg.so
+       else
+               dosym {"../../usr/$(get_libdir)",/opt/zoom}/libturbojpeg.so #715106
+       fi
+
+       make_wrapper zoom ./zoom /opt/zoom
+       make_desktop_entry "zoom %U" Zoom zoom-videocam "" \
+               "MimeType=x-scheme-handler/zoommtg;application/x-zoom;"
+       # The tarball doesn't contain an icon, so take a generic camera icon
+       # from https://github.com/google/material-design-icons, modified to be
+       # white on a blue background
+       doicon -s scalable "${FILESDIR}"/zoom-videocam.svg
+       doicon -s 24 "${FILESDIR}"/zoom-videocam.xpm
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+}