dev-lang/mono: do not call paxctl directly
authorJason Zaman <perfinion@gentoo.org>
Tue, 22 Dec 2015 09:09:01 +0000 (17:09 +0800)
committerJason Zaman <perfinion@gentoo.org>
Tue, 22 Dec 2015 09:09:23 +0000 (17:09 +0800)
paxmark.sh should be used instead which follows XT/PT marks correctly

Gentoo-Bug: https://bugs.gentoo.org/532244

Package-Manager: portage-2.2.24

dev-lang/mono/mono-4.2.1.124.ebuild
dev-lang/mono/mono-4.2.2.10.ebuild

index 83b5c4b3a923ed2cebd53c90f7e84cbc31c01bfa..ee9aa1d3cd654ddeb73aaf38aaf3efda32548bb3 100644 (file)
@@ -51,13 +51,14 @@ pkg_setup() {
 
 src_prepare() {
        # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
-       # get killed in the build proces when MPROTEC is enable. #286280
+       # get killed in the build proces when MPROTECT is enable. #286280
        # RANDMMAP kill the build proces to #347365
+       # use paxmark.sh to get PT/XT logic #532244
        if use pax_kernel ; then
                ewarn "We are disabling MPROTECT on the mono binary."
 
                # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
-               sed '/exec "/ i\paxctl-ng -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+               sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
        fi
 
        # mono build system can fail otherwise
index 83b5c4b3a923ed2cebd53c90f7e84cbc31c01bfa..ee9aa1d3cd654ddeb73aaf38aaf3efda32548bb3 100644 (file)
@@ -51,13 +51,14 @@ pkg_setup() {
 
 src_prepare() {
        # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
-       # get killed in the build proces when MPROTEC is enable. #286280
+       # get killed in the build proces when MPROTECT is enable. #286280
        # RANDMMAP kill the build proces to #347365
+       # use paxmark.sh to get PT/XT logic #532244
        if use pax_kernel ; then
                ewarn "We are disabling MPROTECT on the mono binary."
 
                # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
-               sed '/exec "/ i\paxctl-ng -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+               sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
        fi
 
        # mono build system can fail otherwise