dev-libs/icu-layoutex: Bump to version 60.2
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 12 Dec 2017 12:29:38 +0000 (13:29 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 12 Dec 2017 12:30:22 +0000 (13:30 +0100)
Package-Manager: Portage-2.3.18, Repoman-2.3.6

dev-libs/icu-layoutex/Manifest
dev-libs/icu-layoutex/icu-layoutex-60.2.ebuild [new file with mode: 0644]

index 6b3b0cb516289f11402d55dadc2f8f0186e8b529..ee35700f7675a1519d5b38ba08dec19d9cecca12 100644 (file)
@@ -2,3 +2,4 @@ DIST icu4c-58_1-src.tgz 23366443 BLAKE2B 16f1c778d925893769c6e0f0901fe02e5728953
 DIST icu4c-58_2-src.tgz 23369902 BLAKE2B cdd2e02c3aba050f5b7f8b38c5a3731e3e5f1cc1403ef86a50908b95560ea3cf8a2d47119fa60cf34f22a8b65eaa2392fd5bcbd3bc48b3da541fe3d9bd7392c0 SHA512 5c21af748f48b392e6c0412bd0aee92162ea931820dcbfab4ec6e0299868504b303d88f7586cc95de55c777ac0dca3a29d6c8ca0892c646ebc864c8a5b5a162a
 DIST icu4c-59_1-src.tgz 22706578 BLAKE2B 88ec0b5a174b7f854813c66009aba695b61ec4887b845f092f5b5bf401c416cb2920c596f3f33fee4751bb8ea576a37e991fb18bc845142b322e985224b95879 SHA512 9348aa68d72a74cd1f26588c30c80eee1b48800a26930d7eb0749390fd65f7930ee8843058b6a6dd5f265e79054fef661e807ded16a1ad691cbc5ebc5ab944c4
 DIST icu4c-60_1-src.tgz 23296064 BLAKE2B 4f90c1f4f00b686d2632429fbaa6a6ec3d977e414f8d00cf82a525a1504c9d8c9b1a19458b495e5847abbcfff933038752f96d6bd165d206582f8ec1b77fff40 SHA512 a6798f70add1b3bac2197a49e09a0bb636279af7019ce572f63a30ab713e09657ee9d9b20aac7ea806fbb84667ca2eca981411e5053b47c3c705aa496a669233
+DIST icu4c-60_2-src.tgz 23317794 BLAKE2B 3c65f32676dfa554e8a93a3802ebc72ae9eac2e758e47e579be946169781ec49438fc1c468b834019af971dda092551f4cfb4faa882856620539f7599605543c SHA512 d127410b17dc79b133eb36bcee7f6db441e7e3ec5edc34c142d597718b7b3dbed5b77859ab18770fe4110fce965a2e5d7bb01a923880190ad4044f47ee7102f9
diff --git a/dev-libs/icu-layoutex/icu-layoutex-60.2.ebuild b/dev-libs/icu-layoutex/icu-layoutex-60.2.ebuild
new file mode 100644 (file)
index 0000000..cb059ae
--- /dev/null
@@ -0,0 +1,115 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic toolchain-funcs autotools multilib-minimal
+
+DESCRIPTION="External layout part of International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/"
+SRC_URI="http://download.icu-project.org/files/icu4c/${PV/_/}/icu4c-${PV//./_}-src.tgz"
+
+LICENSE="BSD"
+
+SLOT="0/${PV}"
+
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="
+       ~dev-libs/icu-${PV}[${MULTILIB_USEDEP}]
+       dev-libs/icu-le-hb[${MULTILIB_USEDEP}]
+"
+
+DEPEND="
+       virtual/pkgconfig[${MULTILIB_USEDEP}]
+       ${RDEPEND}
+"
+
+S="${WORKDIR}/${PN/-layoutex}/source"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-58.1-remove-bashisms.patch"
+)
+
+src_prepare() {
+       # apply patches
+       default
+
+       local variable
+
+       # Disable renaming as it is stupid thing to do
+       sed -i \
+               -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" \
+               common/unicode/uconfig.h || die
+
+       # Fix linking of icudata
+       sed -i \
+               -e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
+               config/mh-linux || die
+
+       eautoreconf
+}
+
+src_configure() {
+       # Use C++14
+       append-cxxflags -std=c++14
+
+       if tc-is-cross-compiler; then
+               mkdir "${WORKDIR}"/host || die
+               pushd "${WORKDIR}"/host >/dev/null || die
+
+               CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
+               CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" AR="$(tc-getBUILD_AR)" \
+               RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
+               "${S}"/configure --disable-renaming --disable-debug \
+                       --disable-samples --enable-static || die
+               emake
+
+               popd >/dev/null || die
+       fi
+
+       multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+       local myeconfargs=(
+               --disable-renaming
+               --disable-samples
+               --enable-layoutex
+               $(use_enable debug)
+               $(use_enable static-libs static)
+       )
+
+       tc-is-cross-compiler && myeconfargs+=(
+               --with-cross-build="${WORKDIR}"/host
+       )
+
+       # icu tries to use clang by default
+       tc-export CC CXX
+
+       ECONF_SOURCE=${S} \
+       econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+       # INTLTEST_OPTS: intltest options
+       #   -e: Exhaustive testing
+       #   -l: Reporting of memory leaks
+       #   -v: Increased verbosity
+       # IOTEST_OPTS: iotest options
+       #   -e: Exhaustive testing
+       #   -v: Increased verbosity
+       # CINTLTST_OPTS: cintltst options
+       #   -e: Exhaustive testing
+       #   -v: Increased verbosity
+       pushd layoutex &>/dev/null || die
+       emake -j1 VERBOSE="1" check
+       popd &>/dev/null || die
+}
+
+multilib_src_install() {
+       pushd layoutex &>/dev/null || die
+       default
+       popd &>/dev/null || die
+}