dev-python/brotlipy: Fix Hypothesis deadlines in tests
authorMichał Górny <mgorny@gentoo.org>
Fri, 22 Nov 2019 10:54:59 +0000 (11:54 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 22 Nov 2019 11:44:24 +0000 (12:44 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/brotlipy/brotlipy-0.7.0.ebuild
dev-python/brotlipy/files/brotlipy-0.7.0-test-deadline.patch [new file with mode: 0644]

index dc21af28ce4eea718c3085d3ab5d44b524ba4936..d744a0167224df4dc32c9e0f317a06769cf3ac77 100644 (file)
@@ -33,6 +33,10 @@ DEPEND="
        )
 "
 
+PATCHES=(
+       "${FILESDIR}"/brotlipy-0.7.0-test-deadline.patch
+)
+
 src_prepare() {
        # Inject the brotli lib.
        rm -r "${WORKDIR}/${P}/libbrotli" || die "Could not remove the bundled brotli lib folder."
@@ -41,7 +45,7 @@ src_prepare() {
        # Tests fail if we have this folder preserved within the lib.
        rm -r "${WORKDIR}/${P}/libbrotli/python" || die "Could not remove 'python' subfolder."
 
-       eapply_user
+       distutils-r1_src_prepare
 }
 
 python_test() {
diff --git a/dev-python/brotlipy/files/brotlipy-0.7.0-test-deadline.patch b/dev-python/brotlipy/files/brotlipy-0.7.0-test-deadline.patch
new file mode 100644 (file)
index 0000000..2192439
--- /dev/null
@@ -0,0 +1,28 @@
+diff -dupr a/test/test_simple_compression.py b/test/test_simple_compression.py
+--- a/test/test_simple_compression.py  2017-05-30 10:20:01.000000000 +0200
++++ b/test/test_simple_compression.py  2019-11-22 11:37:31.248755016 +0100
+@@ -9,7 +9,7 @@ import brotli
+ import pytest
+-from hypothesis import given
++from hypothesis import given, settings
+ from hypothesis.strategies import binary, integers, sampled_from, one_of
+@@ -25,6 +25,7 @@ def test_roundtrip_compression_with_file
+     ) == uncompressed_data
++@settings(deadline=None)
+ @given(
+     chunk_size=integers(min_value=1, max_value=2**12),
+     mode=sampled_from(list(brotli.BrotliEncoderMode)),
+@@ -62,6 +63,7 @@ def test_streaming_compression(one_compr
+         assert decompressed == f.read()
++@settings(deadline=None)
+ @given(
+     chunk_size=integers(min_value=1, max_value=2**12),
+     mode=sampled_from(list(brotli.BrotliEncoderMode)),