dev-util/idea-community: Fix unpack error for !jbr11
authorMike Pagano <mpagano@gentoo.org>
Wed, 13 May 2020 17:50:37 +0000 (13:50 -0400)
committerMike Pagano <mpagano@gentoo.org>
Wed, 13 May 2020 17:50:37 +0000 (13:50 -0400)
Closes: https://bugs.gentoo.org/721404
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
dev-util/idea-community/idea-community-2020.1.1.201.7223.91-r1.ebuild

index 1dc6179a1a3a9e5c284e717fbaedc77d9ad2c2eb..d75f70853f1af038daa934174617f76ea18a8f9f 100644 (file)
@@ -61,12 +61,8 @@ QA_PREBUILT="opt/${PN}-${MY_PV}/*"
 
 # jbr11 binary doesn't unpack nicely into a single folder
 src_unpack() {
-       if use !jbr11 ; then
-               default_src_unpack
-       else
-               cd "${WORKDIR}"
-               unpack ${MY_PN}IC-${PV_STRING}.tar.gz
-               cd "${S}"
+       default_src_unpack
+       if use jbr11 ; then
                mkdir jre64 && cd jre64 && unpack jbr-${JRE11_BASE}-linux-x64-b${JRE11_VER}.tar.gz
        fi
 }