dev-python/sip: add -fno-strict-aliasing for python2
authorMike Gilbert <floppym@gentoo.org>
Sun, 7 Oct 2018 13:46:09 +0000 (09:46 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sun, 7 Oct 2018 13:46:09 +0000 (09:46 -0400)
Package-Manager: Portage-2.3.50_p14, Repoman-2.3.11_p21
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-python/sip/sip-4.19.12.ebuild
dev-python/sip/sip-4.19.13.ebuild
dev-python/sip/sip-4.19.8.ebuild
dev-python/sip/sip-4.9999.ebuild

index 6707912b3761fcd3fa0f28d93e03461e1e655a3b..3313a4fac4daef95e73245980f2baf2810a125dc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -69,6 +69,10 @@ src_prepare() {
 
 src_configure() {
        configuration() {
+               if ! python_is_python3; then
+                       local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+               fi
+
                local myconf=(
                        "${PYTHON}"
                        "${S}"/configure.py
index 728a604c424bba007ec8157078d5092884a7e973..3313a4fac4daef95e73245980f2baf2810a125dc 100644 (file)
@@ -69,6 +69,10 @@ src_prepare() {
 
 src_configure() {
        configuration() {
+               if ! python_is_python3; then
+                       local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+               fi
+
                local myconf=(
                        "${PYTHON}"
                        "${S}"/configure.py
index 973f1ae60a0209d9a7fe97fb6709f2c77b689949..bd65f8202bbf5420ddf6f0dbba57d0ec8f9eaf7d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -69,6 +69,10 @@ src_prepare() {
 
 src_configure() {
        configuration() {
+               if ! python_is_python3; then
+                       local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+               fi
+
                local myconf=(
                        "${PYTHON}"
                        "${S}"/configure.py
index 3fe2c1981bd050f901f4d22db377974f807417bd..4df03eb6f4e893773a5873e622d43aa181f3224c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -69,6 +69,10 @@ src_prepare() {
 
 src_configure() {
        configuration() {
+               if ! python_is_python3; then
+                       local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+               fi
+
                local myconf=(
                        "${PYTHON}"
                        "${S}"/configure.py