dev-perl/Crypt-Cracklib: don't "enhance" CFLAGS in Makefile.PL, bug 658000
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Wed, 16 Oct 2019 04:00:25 +0000 (06:00 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Wed, 16 Oct 2019 04:00:25 +0000 (06:00 +0200)
Bug: https://bugs.gentoo.org/658000
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.700.0-r2.ebuild [new file with mode: 0644]
dev-perl/Crypt-Cracklib/files/Crypt-Cracklib-1.700.0-CFLAGS.patch [new file with mode: 0644]

diff --git a/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.700.0-r2.ebuild b/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.700.0-r2.ebuild
new file mode 100644 (file)
index 0000000..19885fe
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DANIEL
+DIST_VERSION=1.7
+inherit perl-module
+
+DESCRIPTION="Perl interface to Alec Muffett's Cracklib"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="sys-libs/cracklib"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-CFLAGS.patch" )
+
+src_prepare() {
+       use test && perl_rm_files t/pod-coverage.t t/pod.t
+       sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+       perl-module_src_prepare
+}
diff --git a/dev-perl/Crypt-Cracklib/files/Crypt-Cracklib-1.700.0-CFLAGS.patch b/dev-perl/Crypt-Cracklib/files/Crypt-Cracklib-1.700.0-CFLAGS.patch
new file mode 100644 (file)
index 0000000..d483d0d
--- /dev/null
@@ -0,0 +1,11 @@
+diff -ruN Crypt-Cracklib-1.7.orig/Makefile.PL Crypt-Cracklib-1.7/Makefile.PL
+--- Crypt-Cracklib-1.7.orig/Makefile.PL        2019-10-16 05:55:37.321262001 +0200
++++ Crypt-Cracklib-1.7/Makefile.PL     2019-10-16 05:56:38.585611172 +0200
+@@ -15,7 +15,6 @@
+ requires_external_cc();
+ cc_lib_links('crack');
+-cc_optimize_flags('-g -Wall -Werror');
+ auto_install();
+ WriteAll();