dev-python/tox: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 09:47:19 +0000 (10:47 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 13:39:09 +0000 (14:39 +0100)
dev-python/tox/Manifest
dev-python/tox/tox-2.7.0.ebuild [deleted file]
dev-python/tox/tox-2.8.1.ebuild [deleted file]

index a0693399d6d6a29d4817c549f455e7a47f0fd143..cbe6d4cc96ab3f5f9f73da1050ec4e56b77adc14 100644 (file)
@@ -1,3 +1 @@
-DIST tox-2.7.0.tar.gz 120139 BLAKE2B 62be94f620c0c818564ab40254a681e7d472b2bf94a9a437847757e3437df8c8f24e01cf58f5616d4d1cef1a6f7797e51868be1a84c8882f5ece8581b61195e2 SHA512 96088a9f77e8b994d920a8c9907a0fa50d5e0fe918e5a67673d4c30810642be2872283810d1d8b5ae9cc311605236b64343248485c4d4067b54c7b6d9f31a4b4
-DIST tox-2.8.1.tar.gz 125777 BLAKE2B bcccc438135a7c3068cb00cb122833bc7774c49d773239013fdbbaf6bb49f5f1aeac2cee79b06766be382218e5185e5f3cea206c0c3f4b22db76a8a04d522b41 SHA512 a230f7bc48f476825ca1a879e669288b311f266f1695bac4eecfcd44076731e5581a425e36555a0db54f8a0683af31abd77ab862aa40525387e6e436ba351c37
 DIST tox-2.9.1.tar.gz 1855982 BLAKE2B 3e2f5fd3d3e45e54f96b0a6fc8f9e98bfba3b48540cc2922a897e016b5aabc9974772c9b897e0fab7b38b00f99478a063ad988ffa8b65fa53f684997334e492c SHA512 ff19b2bb7ac963379f1cccd4973ad9eb4dabfbda976cde7caba50ad010d8fa57c1cba91d63e3e0512e44cc7d350bc9270fbd9b30db1bd55f7d9c239e7623d066
diff --git a/dev-python/tox/tox-2.7.0.ebuild b/dev-python/tox/tox-2.7.0.ebuild
deleted file mode 100644 (file)
index e878943..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="virtualenv-based automation of test activities"
-HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.python.org/pypi/tox"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-
-IUSE="doc test"
-
-# tests need internet
-RESTRICT="test"
-
-RDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/virtualenv-1.11.2[${PYTHON_USEDEP}]
-       dev-python/pluggy[${PYTHON_USEDEP}]
-       dev-python/pip[${PYTHON_USEDEP}]
-       >=dev-python/py-1.4.17[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # remove intersphinx stuff
-       sed -i -e "s/'sphinx.ext.intersphinx',//" doc/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               esetup.py build_sphinx
-               HTML_DOCS=( "${S}"/doc/build/html/. )
-       fi
-}
-
-python_test() {
-       esetup.py test || die "Testsuite failed under ${EPYTHON}"
-}
diff --git a/dev-python/tox/tox-2.8.1.ebuild b/dev-python/tox/tox-2.8.1.ebuild
deleted file mode 100644 (file)
index 095e13a..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="virtualenv-based automation of test activities"
-HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.python.org/pypi/tox"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
-IUSE="doc test"
-
-# tests need internet
-RESTRICT="test"
-
-RDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/virtualenv-1.11.2[${PYTHON_USEDEP}]
-       dev-python/pluggy[${PYTHON_USEDEP}]
-       dev-python/pip[${PYTHON_USEDEP}]
-       >=dev-python/py-1.4.17[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # remove intersphinx stuff
-       sed -i -e "s/'sphinx.ext.intersphinx',//" doc/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               esetup.py build_sphinx
-               HTML_DOCS=( "${S}"/doc/build/html/. )
-       fi
-}
-
-python_test() {
-       esetup.py test || die "Testsuite failed under ${EPYTHON}"
-}