dev-util/cppcheck: Old
authorJeroen Roovers <jer@gentoo.org>
Fri, 18 Jan 2019 08:16:55 +0000 (09:16 +0100)
committerJeroen Roovers <jer@gentoo.org>
Fri, 18 Jan 2019 09:27:09 +0000 (10:27 +0100)
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
dev-util/cppcheck/Manifest
dev-util/cppcheck/cppcheck-1.81.ebuild [deleted file]
dev-util/cppcheck/cppcheck-1.85.ebuild [deleted file]

index ea5ae23f7047c9fd2f7e98a32738ace1a76646a3..db300ae307096d12b944ce7914358620477e5fc4 100644 (file)
@@ -1,3 +1 @@
-DIST cppcheck-1.81.tar.bz2 1514741 BLAKE2B 2f23dfe4bdb26e203411f0bf9bc569303a4d59f96911b32a8a5f9cc9a6a7fa75e5d87c328cb0bf8cc46bd8f38747a4663c33243b8385355cc5630e1fcf6c891f SHA512 22e7b63c35e71b2784065faca06aec8c286e3173f182ac10995073cc3d61fd0bfaf353c51ad9207d3bd2c6134ab1a3990a37668709505b657c2816d561f8af92
-DIST cppcheck-1.85.tar.gz 2150637 BLAKE2B 73a1d4e1fb0770103c8163f35b9e710a5863561df66e46e319b9246ed14e3c5d4d73511db6e70275de4f4510866d7e1888b0fd6b49e5b01fc4f08d081119b36c SHA512 cc984c751d87150839782e96b3762dbf918d9e3687562eabaff6473e48e3254995dd3bffe8605842f867d7ad76845ca2248a53bbd54b5c367281db8a1c1c7fad
 DIST cppcheck-1.86.tar.gz 2184186 BLAKE2B 8b488ec72d0998d6b037de2b1204373c8b3de475ad165bf108bb331399356cb0d1e20a7bc6f368f1a038ec886ad7a84ad694172d0a96a203a6877f3838c21001 SHA512 59cec55b8408e8f2e2e7172bce69350c248bc3185a0938b523c44a58f98b344e11aef957ec1b7a7b2bc7a876660b2683e51f54b76f0b550f9549497c29453655
diff --git a/dev-util/cppcheck/cppcheck-1.81.ebuild b/dev-util/cppcheck/cppcheck-1.81.ebuild
deleted file mode 100644 (file)
index 0604af4..0000000
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1 flag-o-matic qmake-utils toolchain-funcs
-
-DESCRIPTION="Static analyzer of C/C++ code"
-HOMEPAGE="http://cppcheck.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 hppa sparc x86"
-IUSE="htmlreport pcre qt5"
-
-RDEPEND="
-       dev-libs/tinyxml2:=
-       htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
-       pcre? ( dev-libs/libpcre )
-       qt5? (
-               dev-qt/qtcore:5
-               dev-qt/qtgui:5
-               dev-qt/qtprintsupport:5
-       )
-"
-DEPEND="${RDEPEND}
-       app-text/docbook-xsl-stylesheets
-       dev-libs/libxslt
-       virtual/pkgconfig
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.75-tinyxml2.patch )
-
-src_prepare() {
-       default
-       append-cxxflags -std=c++0x
-
-       # Drop bundled libs, patch Makefile generator and re-run it
-       rm -r externals/tinyxml || die
-       tc-export CXX
-       emake dmake
-       ./dmake || die
-}
-
-src_configure() {
-       if use pcre ; then
-               sed -e '/HAVE_RULES=/s:=no:=yes:' \
-                       -i Makefile
-       fi
-}
-
-src_compile() {
-       export LIBS="$(pkg-config --libs tinyxml2)"
-       emake ${PN} man \
-               CFGDIR="${EROOT}usr/share/${PN}/cfg" \
-               DB2MAN="${EROOT}usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
-
-       if use qt5 ; then
-               pushd gui
-               eqmake5
-               emake
-               popd
-       fi
-       if use htmlreport ; then
-               pushd htmlreport
-               distutils-r1_src_compile
-               popd
-       fi
-}
-
-src_test() {
-       # safe final version
-       mv -v ${PN}{,.final}
-       mv -v lib/library.o{,.final}
-       mv -v cli/cppcheckexecutor.o{,.final}
-       #trigger recompile with CFGDIR inside ${S}
-       emake check CFGDIR="${S}/cfg"
-       # restore
-       mv -v ${PN}{.final,}
-       mv -v lib/library.o{.final,}
-       mv -v cli/cppcheckexecutor.o{.final,}
-}
-
-src_install() {
-       # it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
-       emake install DESTDIR="${ED}"
-
-       insinto "/usr/share/${PN}/cfg"
-       doins cfg/*.cfg
-       if use qt5 ; then
-               dobin gui/${PN}-gui
-               dodoc gui/{projectfile.txt,gui.${PN}}
-       fi
-       if use htmlreport ; then
-               pushd htmlreport
-               distutils-r1_src_install
-               popd
-               find "${D}" -name "*.egg-info" -delete
-       else
-               rm "${ED}/usr/bin/cppcheck-htmlreport" || die
-       fi
-       doman ${PN}.1
-       dodoc -r triage
-}
diff --git a/dev-util/cppcheck/cppcheck-1.85.ebuild b/dev-util/cppcheck/cppcheck-1.85.ebuild
deleted file mode 100644 (file)
index 87931e6..0000000
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit distutils-r1 qmake-utils toolchain-funcs
-
-DESCRIPTION="Static analyzer of C/C++ code"
-HOMEPAGE="http://cppcheck.sourceforge.net"
-SRC_URI="https://github.com/danmar/cppcheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
-IUSE="htmlreport pcre qt5"
-
-RDEPEND="
-       dev-libs/tinyxml2:=
-       htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
-       pcre? ( dev-libs/libpcre )
-       qt5? (
-               dev-qt/qtcore:5
-               dev-qt/qtgui:5
-               dev-qt/qtprintsupport:5
-       )
-"
-DEPEND="${RDEPEND}
-       app-text/docbook-xsl-stylesheets
-       dev-libs/libxslt
-       virtual/pkgconfig
-"
-PATCHES=(
-       "${FILESDIR}"/${PN}-1.75-tinyxml2.patch
-       "${FILESDIR}"/${PN}-1.85-ldflags.patch
-)
-
-src_prepare() {
-       default
-
-       rm -r externals/tinyxml || die
-}
-
-src_configure() {
-       tc-export CXX PKG_CONFIG
-       export LIBS="$(${PKG_CONFIG} --libs tinyxml2)"
-
-       emake dmake
-       ./dmake || die
-
-       if use pcre ; then
-               sed -e '/HAVE_RULES=/s:=no:=yes:' \
-                       -i Makefile || die
-       fi
-
-       if use qt5 ; then
-               pushd gui || die
-               eqmake5
-               popd || die
-       fi
-}
-
-src_compile() {
-       emake ${PN} man \
-               CFGDIR="${EROOT}/usr/share/${PN}/cfg" \
-               DB2MAN="${EROOT}/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
-
-       if use qt5 ; then
-               pushd gui || die
-               emake
-               popd || die
-       fi
-
-       if use htmlreport ; then
-               pushd htmlreport || die
-               distutils-r1_src_compile
-               popd || die
-       fi
-}
-
-src_test() {
-       # safe final version
-       mv -v ${PN}{,.final} || die
-       mv -v lib/library.o{,.final} || die
-       mv -v cli/cppcheckexecutor.o{,.final} || die
-       #trigger recompile with CFGDIR inside ${S}
-       emake check CFGDIR="${S}/cfg"
-       # restore
-       mv -v ${PN}{.final,} || die
-       mv -v lib/library.o{.final,} || die
-       mv -v cli/cppcheckexecutor.o{.final,} || die
-}
-
-src_install() {
-       # it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
-       emake install DESTDIR="${ED}"
-
-       insinto "/usr/share/${PN}/cfg"
-       doins cfg/*.cfg
-       if use qt5 ; then
-               dobin gui/${PN}-gui
-               dodoc gui/{projectfile.txt,gui.${PN}}
-       fi
-       if use htmlreport ; then
-               pushd htmlreport || die
-               distutils-r1_src_install
-               popd || die
-               find "${D}" -name "*.egg-info" -delete
-       else
-               rm "${ED}/usr/bin/cppcheck-htmlreport" || die
-       fi
-       doman ${PN}.1
-       dodoc -r triage
-}