Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Canon raw image (CRW) information and thumbnail extractor"
HOMEPAGE="http://freshmeat.net/projects/crwinfo/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE=""
S="${WORKDIR}/CRWInfo-${PV}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}.patch
- sed \
- -e '/gcc/s:^.*$:\t$(CC) $(CFLAGS) -Wall -c crwinfo.c\n\t$(CC) $(LDFLAGS) -o crwinfo crwinfo.o:g' \
- -i Makefile || die
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
+src_compile() {
tc-export CC
+ emake crwinfo
}
src_install() {
---- crwinfo.c.orig 2002-07-30 11:17:03.000000000 -0600
-+++ crwinfo.c 2005-01-21 15:24:54.256888228 -0700
+--- a/crwinfo.c
++++ b/crwinfo.c
@@ -95,10 +95,10 @@
fprintf( stderr, "-m show misc. information (whitepoint, AF mode etc)\n" );
fprintf( stderr, "-f show flash information (flash mode etc)\n" );
fprintf( stderr, "-x show experimental information (don't rely on it)\n" );
exit(0);
}
+--- a/Makefile
++++ b/Makefile
+@@ -1,2 +0,0 @@
+-all:
+- gcc -o crwinfo -W -Wall -g crwinfo.c