dev-java/openjfx: QA: use dodoc and unqoted variables
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Tue, 28 Jan 2020 09:00:47 +0000 (01:00 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Tue, 28 Jan 2020 09:02:01 +0000 (01:02 -0800)
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-java/openjfx/openjfx-11.0.3_p1.ebuild
dev-java/openjfx/openjfx-11.0.6_p2.ebuild

index 8298a8316d0b2e31da8203b131fe52f86a8fb220..0041d39f735e4929d18b00e9c7a755e60a72e95b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -194,7 +194,7 @@ src_configure() {
                LINT = none
                CONF = $(usex debug DebugNative Release)
                NUM_COMPILE_THREADS = $(makeopts_jobs)
-               JFX_DEPS_URL = ${T}/jars
+               JFX_DEPS_URL = "${T}"/jars
                COMPANY_NAME = "Gentoo"
        _EOF_
 }
@@ -213,8 +213,8 @@ src_install() {
        doins build/javafx-exports.zip
 
        if use doc; then
-               insinto /usr/share/doc/"${PF}"/html
-               doins -r build/javadoc/.
+               docinto html
+               dodoc -r build/javadoc/.
                dosym "${EPREFIX}"/usr/share/doc/"${PF}" /usr/share/doc/"${PN}-${SLOT}"
        fi
 }
index e262aab4929aa21fd1c349cdfb44ba9c57c7cc02..956622e2e14f7a9230642422593a2a22ea5ac38c 100644 (file)
@@ -193,7 +193,7 @@ src_configure() {
                LINT = none
                CONF = $(usex debug DebugNative Release)
                NUM_COMPILE_THREADS = $(makeopts_jobs)
-               JFX_DEPS_URL = ${T}/jars
+               JFX_DEPS_URL = "${T}"/jars
                COMPANY_NAME = "Gentoo"
        _EOF_
 }
@@ -212,8 +212,8 @@ src_install() {
        doins build/javafx-exports.zip
 
        if use doc; then
-               insinto /usr/share/doc/"${PF}"/html
-               doins -r build/javadoc/.
+               docinto html
+               dodoc -r build/javadoc/.
                dosym "${EPREFIX}"/usr/share/doc/"${PF}" /usr/share/doc/"${PN}-${SLOT}"
        fi
 }