app-portage/nattka: Bump to 0.0.3
authorMichał Górny <mgorny@gentoo.org>
Sun, 5 Apr 2020 20:20:59 +0000 (22:20 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 5 Apr 2020 20:27:36 +0000 (22:27 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/nattka/Manifest
app-portage/nattka/nattka-0.0.3.ebuild [new file with mode: 0644]

index bfcb28b11dcc652bf8173761de9b8d5f7663731d..31e2970e21850860b9930ccc1ad00fa9750efd9f 100644 (file)
@@ -1 +1,2 @@
 DIST nattka-0.0.2.tar.gz 48458 BLAKE2B 56d20e62b9b56125562afc783ea1344fabb3b3743c1f50a10f6c9cf4f95c83081e7da88b67fbe2bbd3e79ec4542a1ef5bbc712bc644e8a8ab352dc30fd8a63f6 SHA512 186978d2131c686f07e7d193a2532a5b91b7fb389269ec97a5a23ac7e149451f40df6f4afa3be4a633d659ae4a923c62384b71861b5b9a674adffbb44ac67cdd
+DIST nattka-0.0.3.tar.gz 57811 BLAKE2B 68d2fe2b300a4189d4dc7c31c15a41ab86bd3019254cfff55d8aee6543d4ee9bdc1e311640f0d70d4d380993bc170855ee597b8eab2312bf0bbc11c4eac9a942 SHA512 b47837ddf323ed5329c97db326dfef54a4cb604f7b54b1555dd8a4cc43d2f35f04974077e1189c88b04979b9ff1279db2e706571406374dd180061c43efe98e8
diff --git a/app-portage/nattka/nattka-0.0.3.ebuild b/app-portage/nattka/nattka-0.0.3.ebuild
new file mode 100644 (file)
index 0000000..93d9d93
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="https://github.com/mgorny/nattka/"
+SRC_URI="https://github.com/mgorny/nattka/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-util/pkgcheck[${PYTHON_USEDEP}]
+       dev-vcs/git
+       sys-apps/pkgcore[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? ( dev-python/vcrpy[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest