app-arch/bzip2: ensure libbz2.so.1.0 gets installed
authorMike Gilbert <floppym@gentoo.org>
Sat, 11 Apr 2020 17:46:09 +0000 (13:46 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sat, 11 Apr 2020 17:46:48 +0000 (13:46 -0400)
Package-Manager: Portage-2.3.96_p4, Repoman-2.3.22_p1
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
app-arch/bzip2/bzip2-1.0.8-r1.ebuild
app-arch/bzip2/bzip2-9999.ebuild

index e1e25b90ee47cf8f6220b5111ffe3594c1cedcf5..34b92d2ea5417851b2ef81ff7c07a7a264548858 100644 (file)
@@ -71,6 +71,14 @@ multilib_src_install() {
        for v in libbz2.so{,.{${PV%%.*},${PV%.*}}} ; do
                dosym libbz2.so.${PV} /usr/$(get_libdir)/${v}
        done
+
+       # Install libbz2.so.1.0 due to accidental soname change in 1.0.7.
+       # Reference: 98da0ad82192d21ad74ae52366ea8466e2acea24.
+       # OK to remove one year after 2020-04-11.
+       if [[ ! -L "${ED}/usr/$(get_libdir)/libbz2.so.1.0" ]]; then
+               dosym libbz2.so.${PV} "/usr/$(get_libdir)/libbz2.so.1.0"
+       fi
+
        use static-libs && dolib.a libbz2.a
 
        if multilib_is_native_abi ; then
index a0c9cd7a462f729055b2cb52565ea5f1e01884cc..579f0b8f44dd70ff4588eba75608f640ccf2157d 100644 (file)
@@ -36,6 +36,13 @@ multilib_src_compile() {
 multilib_src_install() {
        meson_src_install
 
+       # Install libbz2.so.1.0 due to accidental soname change in 1.0.7.
+       # Reference: 98da0ad82192d21ad74ae52366ea8466e2acea24.
+       # OK to remove one year after 2020-04-11.
+       if [[ ! -L "${ED}/usr/$(get_libdir)/libbz2.so.1.0" ]]; then
+               dosym libbz2.so.1 "/usr/$(get_libdir)/libbz2.so.1.0"
+       fi
+
        if multilib_is_native_abi ; then
                gen_usr_ldscript -a bz2