dev-ml/ocamlnet: remove ancient 3.7.7-r1
authortomboy64 <tomboy64@sina.cn>
Thu, 20 Apr 2017 15:45:29 +0000 (17:45 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 20 Apr 2017 17:06:30 +0000 (19:06 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-ml/ocamlnet/Manifest
dev-ml/ocamlnet/metadata.xml
dev-ml/ocamlnet/ocamlnet-3.7.7-r1.ebuild [deleted file]

index ad98e1aa65406c86cb6317ecc208ea968a8ea3c1..ae3ae742c7332e76c7ee898aa4371ec79a7ae275 100644 (file)
@@ -1,2 +1 @@
-DIST ocamlnet-3.7.7.tar.gz 3357674 SHA256 5b8e464a874018c5e48fc1edc752b83e014061f19316b5b14df8422d939e7609 SHA512 b500a92e6c5dc4d96ac26352923d78cb3a8b555deda038c41860aecbd20ee9ccbcfee949014c91f1266c937ae03fadd72c322e3cbe6456d23fd20b871114df6a WHIRLPOOL ceb4a9fc5d43fe89487589ae14c4bdf58d6c3d99d3a9ebc07fa722e894106899a2ae2aca91a47338d8004017fdd0d23632e187d96ec51479b43955daddbbb893
 DIST ocamlnet-4.1.2.tar.gz 4623183 SHA256 918c3921529cfe545e206b3535a58f43f665165044dd3548f685b583e94f14d8 SHA512 69f42042a54efd662db2217224da53513fc7e72c7b2313d4a4a1128f1b4624f4f6298434f5b19f354b832119ff151abc81e85eb0108d6eb24f30f82d176e0b4d WHIRLPOOL 27e1a8eb24361cadb8b2fb2b61bc6e93d71be8290873ca5bb1eebe16b9c9b1db69eae3b20c8deb3f6656aa79171a817b15acae53159d80ff8f4c946c201de173
index 0aeeb6fb950537691759773ec60e4e9194909baa..196389cbbc7c1b7fb879d67d1130d2bf5a7f4b44 100644 (file)
@@ -6,7 +6,6 @@
        <name>Gentoo ML Project</name>
        </maintainer>
 <use>
-       <flag name="cryptokit">Enables encryption support via <pkg>dev-ml/cryptokit</pkg></flag>
        <flag name="httpd">Enables net-httpd web server component</flag>
        <flag name="zip">Enables netzip support to read/write gzip data using object channels</flag>
 </use>
diff --git a/dev-ml/ocamlnet/ocamlnet-3.7.7-r1.ebuild b/dev-ml/ocamlnet/ocamlnet-3.7.7-r1.ebuild
deleted file mode 100644 (file)
index 0ddf57e..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils findlib
-
-MY_P=${P/_beta/test}
-DESCRIPTION="Modules for OCaml application-level Internet protocols"
-HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
-SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
-
-LICENSE="ZLIB GPL-2+"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-IUSE="cryptokit gtk ssl tk httpd +ocamlopt +pcre zip"
-RESTRICT="installsources"
-
-# the auth-dh compile flag has been disabled as well, since it depends on
-# ocaml-cryptgps, which is not available.
-
-DEPEND=">=dev-ml/findlib-1.0
-               pcre? ( >=dev-ml/pcre-ocaml-5:= )
-               >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
-               tk? ( dev-ml/labltk:= )
-               cryptokit? ( dev-ml/cryptokit:= )
-               gtk? ( >=dev-ml/lablgtk-2:= )
-               ssl? ( >=dev-ml/ocaml-ssl-0.4:= )
-               zip? ( dev-ml/camlzip:= )
-               "
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-ocamlnet_use_with() {
-       if use $1; then
-               echo "-with-$2"
-       else
-               echo "-without-$2"
-       fi
-}
-
-ocamlnet_use_enable() {
-       if use $1; then
-               echo "-enable-$2"
-       else
-               echo "-disable-$2"
-       fi
-}
-
-src_configure() {
-       ./configure \
-               -bindir /usr/bin \
-               -datadir /usr/share/${PN} \
-               $(ocamlnet_use_enable cryptokit crypto) \
-               $(ocamlnet_use_enable gtk gtk2) \
-               $(ocamlnet_use_enable pcre pcre) \
-               $(ocamlnet_use_enable ssl ssl) \
-               $(ocamlnet_use_enable tk tcl) \
-               $(ocamlnet_use_enable zip zip) \
-               $(ocamlnet_use_with httpd nethttpd) \
-               || die "Error : econf failed!"
-}
-
-src_compile() {
-       emake -j1 all
-       if use ocamlopt; then
-               emake -j1 opt
-       fi
-}
-
-src_install() {
-       export STRIP_MASK="*/bin/*"
-       findlib_src_install
-}