dev-python/llfuse-1.3.6: bump, EAPI=7, py38
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 13 May 2020 02:23:05 +0000 (19:23 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 13 May 2020 02:33:38 +0000 (19:33 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/llfuse/Manifest
dev-python/llfuse/llfuse-1.3.6.ebuild [new file with mode: 0644]

index cd481d00bcb9cccf1e257be443f54e9bb581458e..bffbed16dc63bd97212cf887a06d5f54e085e741 100644 (file)
@@ -1 +1,2 @@
 DIST llfuse-1.3.5.tar.bz2 362266 BLAKE2B 561439e193470c047aa32b5b4ffd189beca2496b0141d9f0b0d4b494ee135025b174744ac3c90a0e5e8a17cc98f4ab2e8b4a9069f7d73e01a369f5013d036144 SHA512 d45c5fe7e81fd561e016fe99cc7bbac0cf6243e1517e992fe5b302b641aa93c8f95779cb7a4add7a7479f1ed6ca35e0fcf1e4da0fc46ee5d819b46511927613c
+DIST llfuse-1.3.6.tar.bz2 361750 BLAKE2B 74387a6aeb28c3f49234a4f430c3f2aaeefa2057d69e681405d9588c63b3a6e4a6daa58b8996541825c73ff4dabc5607874c2d7885586d793a6436e3f680aec2 SHA512 d67e39daf65c92ebb5bf69abb0c5dc3a88460228b5ec5ee762a11fc909369562411297e8ff9f512ee1ef539d8abec765924be581703fb7e99963c6512cb1f0bd
diff --git a/dev-python/llfuse/llfuse-1.3.6.ebuild b/dev-python/llfuse/llfuse-1.3.6.ebuild
new file mode 100644 (file)
index 0000000..1249f8f
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://github.com/python-llfuse/python-llfuse/ https://pypi.org/project/llfuse/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+       >=sys-fs/fuse-2.8.0:0
+"
+DEPEND="
+       sys-apps/attr
+       virtual/pkgconfig
+"
+
+PATCHES=(
+       "${FILESDIR}"/llfuse-1.3.5-cflags.patch
+)
+
+distutils_enable_tests pytest
+
+python_install_all() {
+       use doc && local HTML_DOCS=( doc/html/. )
+       use examples && dodoc -r examples
+       distutils-r1_python_install_all
+}