app-emulation/spice-html5: adding for nova
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 20 Apr 2019 01:28:45 +0000 (20:28 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 20 Apr 2019 01:32:15 +0000 (20:32 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-emulation/spice-html5/Manifest [new file with mode: 0644]
app-emulation/spice-html5/metadata.xml [new file with mode: 0644]
app-emulation/spice-html5/spice-html5-0.2.1.ebuild [new file with mode: 0644]

diff --git a/app-emulation/spice-html5/Manifest b/app-emulation/spice-html5/Manifest
new file mode 100644 (file)
index 0000000..0d42721
--- /dev/null
@@ -0,0 +1 @@
+DIST spice-html5-spice-html5-0.2.1.tar.gz 486871 BLAKE2B 4b44ad772ab5abf13e8d3fe7c651169b340c8978f4163b9b679046efaa554f86d5919d154f16262ea28ddb512ac55ea7b6651ae63f64cf6b69033d8306191dc3 SHA512 c6e17aa465da1a0b882184bb19f2560f43fd3b345fdc00ec71774c7aec37c3453fd87b2448202011e217dda21b602d20dd4d552d49d9a52b64cb91aff092eff7
diff --git a/app-emulation/spice-html5/metadata.xml b/app-emulation/spice-html5/metadata.xml
new file mode 100644 (file)
index 0000000..86afbba
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>openstack@gentoo.org</email>
+               <name>Openstack</name>
+       </maintainer>
+       <longdescription lang="en">
+               Spice Javascript client
+       </longdescription>
+</pkgmetadata>
diff --git a/app-emulation/spice-html5/spice-html5-0.2.1.ebuild b/app-emulation/spice-html5/spice-html5-0.2.1.ebuild
new file mode 100644 (file)
index 0000000..96b0048
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Spice Javascript client"
+HOMEPAGE="https://gitlab.freedesktop.org/spice/spice-html5"
+SRC_URI="https://gitlab.freedesktop.org/spice/${PN}/-/archive/${P}/${PN}-${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+# no compiling
+src_compile() {
+       true
+}
+
+src_install() {
+       insinto /usr/share/spice-html5
+       doins -r src apache.conf.sample spice.css spice.html spice_auto.html
+}