gnustep-base/gnustep-make: 2.8.0 bump
authorBernard Cafarelli <voyageur@gentoo.org>
Sat, 9 May 2020 13:10:19 +0000 (15:10 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Sat, 9 May 2020 14:24:58 +0000 (16:24 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
gnustep-base/gnustep-make/Manifest
gnustep-base/gnustep-make/gnustep-make-2.8.0.ebuild [new file with mode: 0644]

index 705339a325ac32c634b4418d46070e5b0375f251..77bb8cfab23efb4d06808d27cd22901314b5bd49 100644 (file)
@@ -1,2 +1,3 @@
 DIST gnustep-make-2.6.8.tar.gz 592266 BLAKE2B 12ad6d1b27f3280f99c55d78a899983527620fbb6ec9a7d70bd71917e0d615e62d4930ceb39c3ea3d340749896226a528d18d322629e05cba3a6f636be4b0a47 SHA512 1df6757cd1e0dbca3eb6e4ad4346406799ebb2782f5853014cc3b1e8ae47056026e6c5cd43e5671c8802232444602fde164dde352c15b4e0d64bdfdea06bd8a0
 DIST gnustep-make-2.7.0.tar.gz 596399 BLAKE2B 85c23795bbaaa7ca3a2166d96a1bc6be3506501721ee5bee4fa8513c490affabce7d4f60a13ba3b33f642c73f08afb4e30ba48da4d1b3bcfd17df3ec9b85b8b6 SHA512 7a39c2c79f01c3a93607bba71ef8c482d0610541ebcb3d0ffce6c1a104a74646329d18255a8bd183ccf54f37018e4d6b4a9d8adf419e2cdea29b35c89e81d9a2
+DIST gnustep-make-2.8.0.tar.gz 606337 BLAKE2B b4defb8fdd8fc17ce2ac14c7d3d63b85e817bb639b7c1ae6a150baf74cda222ac046d890e677b50398bb9953e1496a98e9eb542809c961243f4f620276ab13fb SHA512 e9e57ed7a1c360c2dbf17f70d38e5107a1a9613842dcc645f10ed7a01eb9f9ee71bd2d0cacbe00439ce73f194a3eb3ed2e71409241ac96ee3bba704dcf6dfd7b
diff --git a/gnustep-base/gnustep-make/gnustep-make-2.8.0.ebuild b/gnustep-base/gnustep-make/gnustep-make-2.8.0.ebuild
new file mode 100644 (file)
index 0000000..2fdb433
--- /dev/null
@@ -0,0 +1,132 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnustep-base prefix toolchain-funcs
+
+DESCRIPTION="GNUstep Makefile Package"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="libobjc2 native-exceptions"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+       >=sys-devel/make-3.75
+       libobjc2? ( gnustep-base/libobjc2
+               sys-devel/clang )
+       !libobjc2? ( !!gnustep-base/libobjc2
+               || (
+                       >=sys-devel/gcc-3.3[objc]
+                       sys-devel/clang
+               ) )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+       # Determine libobjc.so to use
+       if use libobjc2; then
+               libobjc_version=libobjc.so.4
+       else
+               # Find version in active gcc
+               for ver in {2..5};
+               do
+                       if $(tc-getCC) -Werror -Wl,-l:libobjc.so.${ver} -x objective-c \
+                               - <<<$'int main() {}' -o /dev/null 2> /dev/null;
+                       then
+                               libobjc_version=libobjc.so.${ver}
+                       fi
+               done
+       fi
+
+       # Stop if we could not get libobjc.so
+       if [[ -z ${libobjc_version} ]]; then
+               eerror "${P} requires a working Objective-C runtime and a compiler with"
+               eerror "Objective-C support. Your current settings lack these requirements"
+               if ! use libobjc2;
+               then
+                       eerror "Please switch your active compiler to gcc with USE=objc, or clang"
+               fi
+               die "Could not find Objective-C runtime"
+       fi
+
+       # For existing installations, determine if we will use another libobjc.so
+       if has_version gnustep-base/gnustep-make; then
+               local current_libobjc="$(awk -F: '/^OBJC_LIB_FLAG/ {print $2}' ${EPREFIX}/usr/share/GNUstep/Makefiles/config.make)"
+               # Old installations did not set this explicitely
+               : ${current_libobjc:=libobjc.so.2}
+
+               if [[ ${current_libobjc} != ${libobjc_version} ]]; then
+                       ewarn "Warning: changed libobjc.so version!!"
+                       ewarn "The libobjc.so version used for gnustep-make has changed"
+                       ewarn "(either by the libojbc2 use-flag or a GCC upgrade)"
+                       ewarn "You must rebuild all gnustep packages installed."
+                       ewarn ""
+                       ewarn "To do so, please emerge gnustep-base/gnustep-updater and run:"
+                       ewarn "# gnustep-updater -l"
+               fi
+       fi
+
+       if use libobjc2; then
+               export CC=clang
+       fi
+}
+
+src_prepare() {
+       # Multilib-strict
+       sed -e "s#/lib#/$(get_libdir)#" -i FilesystemLayouts/fhs-system || die "sed failed"
+       cp "${FILESDIR}"/gnustep-5.{csh,sh} "${T}"/
+       eprefixify "${T}"/gnustep-5.{csh,sh}
+
+       default
+}
+
+src_configure() {
+       econf \
+               INSTALL="${EPREFIX}"/usr/bin/install \
+               --with-layout=fhs-system \
+               --with-config-file="${EPREFIX}"/etc/GNUstep/GNUstep.conf \
+               --with-objc-lib-flag=-l:${libobjc_version} \
+               $(use_enable native-exceptions native-objc-exceptions)
+}
+
+src_compile() {
+       emake
+       if use doc ; then
+               emake -C Documentation
+       fi
+}
+
+src_install() {
+       # Get GNUSTEP_* variables
+       . ./GNUstep.conf
+
+       local make_eval
+       use debug || make_eval="${make_eval} debug=no"
+       make_eval="${make_eval} verbose=yes"
+
+       emake ${make_eval} DESTDIR="${D}" install
+
+       # Copy the documentation
+       if use doc ; then
+               emake -C Documentation ${make_eval} DESTDIR="${D}" install
+       fi
+
+       dodoc FAQ README RELEASENOTES
+
+       exeinto /etc/profile.d
+       doexe "${T}"/gnustep-?.sh
+       doexe "${T}"/gnustep-?.csh
+}
+
+pkg_postinst() {
+       # Warn about new layout if old GNUstep directory is still here
+       if [ -e /usr/GNUstep/System ]; then
+               ewarn "Old layout directory detected (/usr/GNUstep/System)"
+               ewarn "Gentoo has switched to FHS layout for GNUstep packages"
+               ewarn "You must first update the configuration files from this package,"
+               ewarn "then remerge all packages still installed with the old layout"
+               ewarn "You can use gnustep-base/gnustep-updater for this task"
+       fi
+}