dev-python/astroid: Raise minimum dev-python/wrapt version to 1.11.2
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Mar 2020 20:18:03 +0000 (21:18 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Mar 2020 20:18:03 +0000 (21:18 +0100)
Bug: https://bugs.gentoo.org/710282
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/astroid/astroid-2.3.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/astroid/astroid-2.3.3-r1.ebuild b/dev-python/astroid/astroid-2.3.3-r1.ebuild
new file mode 100644 (file)
index 0000000..3227a43
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="https://github.com/PyCQA/astroid https://pypi.org/project/astroid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+       dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       >=dev-python/wrapt-1.11.2[${PYTHON_USEDEP}]
+       >=dev-python/typed-ast-1.3.0[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/numpy[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/python-dateutil[${PYTHON_USEDEP}]
+       )"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-2.3.3-no-pytest-runner.patch"
+)
+
+python_prepare_all() {
+       # Disable failing tests
+
+       # no idea why this test fails
+       sed -i -e "s/test_knownValues_get_builtin_module_part/_&/" \
+               astroid/tests/unittest_modutils.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       "${EPYTHON}" -m pytest -v --pyarg astroid/tests \
+               || die "tests failed with ${EPYTHON}"
+}