dev-python/python-gnupg: drop old versions
authorConrad Kostecki <conikost@gentoo.org>
Fri, 20 Dec 2019 19:40:39 +0000 (20:40 +0100)
committerConrad Kostecki <conikost@gentoo.org>
Fri, 20 Dec 2019 19:42:54 +0000 (20:42 +0100)
Bug: https://bugs.gentoo.org/685864
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
dev-python/python-gnupg/Manifest
dev-python/python-gnupg/files/python-gnupg-0.4.3-skip_network_needing_test.patch [deleted file]
dev-python/python-gnupg/files/python-gnupg-0.4.3-use_seperate_keys_directory.patch [deleted file]
dev-python/python-gnupg/python-gnupg-0.4.0.ebuild [deleted file]
dev-python/python-gnupg/python-gnupg-0.4.1.ebuild [deleted file]
dev-python/python-gnupg/python-gnupg-0.4.3.ebuild [deleted file]

index 59abc83a1f6f4be9f1c99c83956259b9fb48bf26..7b1efc11dc6d925ac30f9c721e68e1433cb9ff6c 100644 (file)
@@ -1,4 +1 @@
-DIST python-gnupg-0.4.0.tar.gz 43987 BLAKE2B 59e72f894c5d554ba2a7c348ad3625500798ad6ac18332a3bb668b42559f52b58e3cd0f8b79ef1a99f37e796b48169d0bf36414e938e9039784cede4303cbb03 SHA512 f486ec97aee01cf46d055421211ff5704093a382155043b7ced6f809dc15d7669d5869038a1b26c5f1831076d85c929d781bc22e35ab293a14bc6e2f5f27fa32
-DIST python-gnupg-0.4.1.tar.gz 44534 BLAKE2B 0b58312b9f094b29f7009bb7a44ea3607be826ae2fda958dae0ba9dd5a2d7f81843fe23a6fe336b9df85c059e5b114787dab372df42b14b83cb73fb02abee919 SHA512 0920a1de4d98a745f7747280672975db04c40b59ea4436745cdbefa86a0c88bfdc086d6dd312c82a0a9e9f8cafb5651f8e17d86e0ee37282b5fc36e7ac8d1a1e
-DIST python-gnupg-0.4.3.tar.gz 46958 BLAKE2B c83b13f8b36c136ac75e8a69dccb07025be3397284e27d9624677cd76ac8527bed67644be7a00958fdb248772a0c37de09257fb711eb16a2c982dbca0368dbd6 SHA512 9381acb1246b6ceec4de21091f2ce57dba9c6600dfb52ddee181effbd2e749d18935e6b6bb2183816064e9129cd1bb3ebfdd28a5dcddc9be1c56261a501067d8
 DIST python-gnupg-0.4.5.tar.gz 48792 BLAKE2B 1bf9cc1c8efafd4fa783574724852d0f168d4d4d4ec188bade9a3ff21be61cc1b087bd4ae72f11f189d182cd49c765d9b57ef22d954a69555c0368f1d863f1fd SHA512 441b49e1f87a7e8e3abf2d6e90f677dc33f1b66a36483787f972378127f31308bacc5e200ae254dd75942191d2fabd61ca5a2f200cf5400be70957942f889ca4
diff --git a/dev-python/python-gnupg/files/python-gnupg-0.4.3-skip_network_needing_test.patch b/dev-python/python-gnupg/files/python-gnupg-0.4.3-skip_network_needing_test.patch
deleted file mode 100644 (file)
index f6df143..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# HG changeset patch
-# User Vinay Sajip <vinay_sajip@yahoo.co.uk>
-# Date 1528916733 -3600
-# Node ID f16d4e17cf349cf9ee561e117262a4041e4fe2ee
-# Parent  60ece27e564ef381392dc19a544aa289fb598c7e
-Conditionally skip tests that rely on flaky external servers/networks.
-
-diff --git a/gnupg.py b/gnupg.py
---- a/gnupg.py
-+++ b/gnupg.py
-@@ -1118,7 +1118,7 @@
-         >>> gpg = GPG(gpgbinary=GPGBINARY, gnupghome="keys")
-         >>> os.chmod('keys', 0x1C0)
-         >>> result = gpg.recv_keys('pgp.mit.edu', '92905378')
--        >>> assert result
-+        >>> if 'NO_EXTERNAL_TESTS' not in os.environ: assert result
-         """
-         result = self.result_map['import'](self)
-@@ -1321,7 +1321,7 @@
-         >>> gpg = GPG(gpgbinary=GPGBINARY, gnupghome='keys')
-         >>> os.chmod('keys', 0x1C0)
-         >>> result = gpg.search_keys('<vinay_sajip@hotmail.com>')
--        >>> assert result, 'Failed using default keyserver'
-+        >>> if 'NO_EXTERNAL_TESTS' not in os.environ: assert result, 'Failed using default keyserver'
-         >>> #keyserver = 'keyserver.ubuntu.com'
-         >>> #result = gpg.search_keys('<vinay_sajip@hotmail.com>', keyserver)
-         >>> #assert result, 'Failed using keyserver.ubuntu.com'
-diff --git a/test_gnupg.py b/test_gnupg.py
---- a/test_gnupg.py
-+++ b/test_gnupg.py
-@@ -836,12 +836,13 @@
-     #@skipIf(os.name == 'nt', 'Test not suitable for Windows')
-     def test_search_keys(self):
-         "Test that searching for keys works"
--        r = self.gpg.search_keys('<vinay_sajip@hotmail.com>')
--        self.assertTrue(r)
--        self.assertTrue('Vinay Sajip <vinay_sajip@hotmail.com>' in r[0]['uids'])
--        r = self.gpg.search_keys('92905378')
--        self.assertTrue(r)
--        self.assertTrue('Vinay Sajip <vinay_sajip@hotmail.com>' in r[0]['uids'])
-+        if 'NO_EXTERNAL_TESTS' not in os.environ:
-+            r = self.gpg.search_keys('<vinay_sajip@hotmail.com>')
-+            self.assertTrue(r)
-+            self.assertTrue('Vinay Sajip <vinay_sajip@hotmail.com>' in r[0]['uids'])
-+            r = self.gpg.search_keys('92905378')
-+            self.assertTrue(r)
-+            self.assertTrue('Vinay Sajip <vinay_sajip@hotmail.com>' in r[0]['uids'])
-     def test_quote_with_shell(self):
-         "Test shell quoting with a real shell"
diff --git a/dev-python/python-gnupg/files/python-gnupg-0.4.3-use_seperate_keys_directory.patch b/dev-python/python-gnupg/files/python-gnupg-0.4.3-use_seperate_keys_directory.patch
deleted file mode 100644 (file)
index b571372..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# HG changeset patch
-# User Vinay Sajip <vinay_sajip@yahoo.co.uk>
-# Date 1534104706 -3600
-# Node ID aeb916c839c0f556dae96bb1136be760ccc19cfe
-# Parent  1a5795e58fe216c1227a11d169dbe4c09c625d15
-Fixed problem with a fixed 'keys' homedir on slow/busy systems (see PR #24).
-
-diff --git a/test_gnupg.py b/test_gnupg.py
---- a/test_gnupg.py
-+++ b/test_gnupg.py
-@@ -173,11 +173,14 @@
- class GPGTestCase(unittest.TestCase):
-     def setUp(self):
--        hd = os.path.join(os.getcwd(), 'keys')
--        if os.path.exists(hd):
--            self.assertTrue(os.path.isdir(hd),
--                            "Not a directory: %s" % hd)
--            shutil.rmtree(hd, ignore_errors=True)
-+        if 'STATIC_TEST_HOMEDIR' not in os.environ:
-+            hd = tempfile.mkdtemp(prefix='keys-')
-+        else:
-+            hd = os.path.join(os.getcwd(), 'keys')
-+            if os.path.exists(hd):
-+                self.assertTrue(os.path.isdir(hd),
-+                                "Not a directory: %s" % hd)
-+                shutil.rmtree(hd, ignore_errors=True)
-         prepare_homedir(hd)
-         self.homedir = hd
-         self.gpg = gpg = gnupg.GPG(gnupghome=hd, gpgbinary=GPGBINARY)
-@@ -193,6 +196,10 @@
-             data_file.write(os.urandom(5120 * 1024))
-             data_file.close()
-+    def tearDown(self):
-+        if 'STATIC_TEST_HOMEDIR' not in os.environ:
-+            shutil.rmtree(self.homedir, ignore_errors=True)
-+
-     def test_environment(self):
-         "Test the environment by ensuring that setup worked"
-         hd = self.homedir
-@@ -373,7 +380,7 @@
-             # and the keyring file name has changed.
-             pkn = 'pubring.kbx'
-             skn = None
--        hd = os.path.join(os.getcwd(), 'keys')
-+        hd = self.homedir
-         if os.name == 'posix':
-             pkn = os.path.join(hd, pkn)
-             if skn:
diff --git a/dev-python/python-gnupg/python-gnupg-0.4.0.ebuild b/dev-python/python-gnupg/python-gnupg-0.4.0.ebuild
deleted file mode 100644 (file)
index 896d81c..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for GNU Privacy Guard"
-HOMEPAGE="https://pythonhosted.org/python-gnupg/ https://github.com/vsajip/python-gnupg/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-
-RDEPEND="app-crypt/gnupg"
-DEPEND="${RDEPEND}"
-
-# They hung. We haven't figured out why yet.
-RESTRICT="test"
-
-python_test() {
-       # Note; 1 test fails under pypy only
-       "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/python-gnupg/python-gnupg-0.4.1.ebuild b/dev-python/python-gnupg/python-gnupg-0.4.1.ebuild
deleted file mode 100644 (file)
index 9c2d9ed..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for GNU Privacy Guard"
-HOMEPAGE="https://pythonhosted.org/python-gnupg/ https://github.com/vsajip/python-gnupg/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-
-RDEPEND="app-crypt/gnupg"
-DEPEND="${RDEPEND}"
-
-# Tests are still hanging.
-RESTRICT="test"
-
-python_test() {
-       # Note; 1 test fails under pypy only
-       "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/python-gnupg/python-gnupg-0.4.3.ebuild b/dev-python/python-gnupg/python-gnupg-0.4.3.ebuild
deleted file mode 100644 (file)
index 5eaa270..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( pypy{,3} python2_7 python3_{5,6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python wrapper for GnuPG"
-HOMEPAGE="https://bitbucket.org/vinay.sajip/python-gnupg
-       https://pypi.org/project/python-gnupg/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND="app-crypt/gnupg"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-skip_network_needing_test.patch
-       "${FILESDIR}"/${P}-use_seperate_keys_directory.patch
-)
-
-python_test() {
-       # NO_EXTERNAL_TESTS must be enabled,
-       # to disable all tests, which need internet access.
-       NO_EXTERNAL_TESTS=1 "${PYTHON}" test_gnupg.py || die "Tests failed with ${EPYTHON}"
-}