dev-python/tld: 0.12.1 bump
authorBernard Cafarelli <voyageur@gentoo.org>
Sun, 3 May 2020 10:14:57 +0000 (12:14 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Sun, 3 May 2020 10:15:52 +0000 (12:15 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
dev-python/tld/Manifest
dev-python/tld/tld-0.12.1.ebuild [new file with mode: 0644]

index 994dca432d8bdccdbf8066906a9aca5d321285b0..8d6f5eabd08e4970691c22775a5b1a888c507034 100644 (file)
@@ -1 +1,2 @@
 DIST tld-0.11.10.tar.gz 1345092 BLAKE2B c8451bb7bf8be75b6ccfab8a797f5f79a8b8e7992e73ea3f93b227a4f092feafba675dc7656bb7021cc4ffab2a95532ad50a9492e23878416612b23e6a0a0555 SHA512 c2eeaddd52d0e6e1aa42b6018cc4ce2e80630371c1223217bfc8761440231630fedb26ef3714a33c978c546045a08b36b90a8f2591af146ee2282b24b283c308
+DIST tld-0.12.1.tar.gz 1346595 BLAKE2B 393c052872218212ef13ee60d011ed5fc0ee8eea37530081b43004c3e4d9e64a6198df1191a4e28032a1ee8ab884d52297995e138f830d81a4bd8484e9aa72f2 SHA512 eeaab86528fdd516f8e8ff42bd04432d6c1bea995c673563630a2b849705ec08450e592c39f9f5e649ced93548443a766507474222cce31b86ef0fc400d766f2
diff --git a/dev-python/tld/tld-0.12.1.ebuild b/dev-python/tld/tld-0.12.1.ebuild
new file mode 100644 (file)
index 0000000..73e3367
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Extract the top level domain (TLD) from the URL given"
+HOMEPAGE="https://github.com/barseghyanartur/tld"
+SRC_URI="https://github.com/barseghyanartur/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""