dev-python/grpcio: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 10:39:18 +0000 (11:39 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 10:42:38 +0000 (11:42 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/grpcio/Manifest
dev-python/grpcio/files/grpc-1.22.1-glibc-2.30-compat.patch [deleted file]
dev-python/grpcio/grpcio-1.22.1.ebuild [deleted file]
dev-python/grpcio/grpcio-1.23.0.ebuild [deleted file]
dev-python/grpcio/grpcio-1.24.3.ebuild [deleted file]

index b6c0017e638bcac7419d19c5e273867f391cdd85..bff63af10b65e51dbb7dff08387ae5c91039fe31 100644 (file)
@@ -1,4 +1 @@
-DIST grpcio-1.22.1.tar.gz 13923342 BLAKE2B 6d211b93a7597f568d106e0d6e3d30b90d7b4bf6fae42b163f2ae04e01c4b323c4d7c2a5380ccdbab14f9a6986c86fae4948bc827a97c189f915bc24738fc426 SHA512 5392041a021b0523fc7a615070ea0f907fc960cb69ffba1e7fcdf0aa8e498cb33f567d9eec795dc06662f558884dcabcc17a1ae4a26fcaa479b0a43c08e8b913
-DIST grpcio-1.23.0.tar.gz 13977223 BLAKE2B b9f95aaf397eae9610280937980e4b2694af98e6cd5f80015dd83c67ec6bf9c41e76474f873627d6c6cc35fe9af3b45f14aabb6ea809b51cf5f0bb0f3b702794 SHA512 ff3cd9d2380a158ea7a49ba2c9cd5bd1ec98194aa48cf2d45596ab93f0e8a6d6ed0291e5dfc52bca79c62950e6a0ce387819d19f036c0dd1e6dc7b737c1ee97f
-DIST grpcio-1.24.3.tar.gz 14030592 BLAKE2B aa9e61c692937d7fc06d0fb601f7632a6ac5fb165aabec9e7993cf1fa41254b004fff89f650f390544e5fb1972dca542169ce0fdae79a71d775fe3cbb44a2d95 SHA512 0dc90de5a06b9af7fa91d3e96117f69813e5fee31499e8e48daac7d164856594f164a434d3dd28d6e0220e417926aadceabb9b7597e86a6bb87d8943e6661dce
 DIST grpcio-1.26.0.tar.gz 15406206 BLAKE2B 4a9031e1d9e9285d1c1ee90396ae339a47715fa2c279f5bce517e3ea02bdc755e3044e3e402f73b3d797a6b1415f58396097a55ba16200c7f9d4569b0b159fe3 SHA512 df3b6787449c202f3e70640907c76231dbbeb6b411167300ba8a53c17f7d45ffa513a81046a4a66a368f2c17c2d57a48a07cb236f44a005e4073bd5d8aa3865c
diff --git a/dev-python/grpcio/files/grpc-1.22.1-glibc-2.30-compat.patch b/dev-python/grpcio/files/grpc-1.22.1-glibc-2.30-compat.patch
deleted file mode 100644 (file)
index 90bd911..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-From d1d017390b799c59d6fdf7b8afa6136d218bdd61 Mon Sep 17 00:00:00 2001
-From: Benjamin Peterson <benjamin@dropbox.com>
-Date: Fri, 3 May 2019 08:11:00 -0700
-Subject: [PATCH] Rename gettid() functions.
-
-glibc 2.30 will declare its own gettid; see https://sourceware.org/git/?p=glibc.git;a=commit;h=1d0fc213824eaa2a8f8c4385daaa698ee8fb7c92. Rename the grpc versions to avoid naming conflicts.
----
- src/core/lib/gpr/log_linux.cc          | 4 ++--
- src/core/lib/gpr/log_posix.cc          | 4 ++--
- src/core/lib/iomgr/ev_epollex_linux.cc | 4 ++--
- 3 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/src/core/lib/gpr/log_linux.cc b/src/core/lib/gpr/log_linux.cc
-index 561276f0c20..8b597b4cf2f 100644
---- a/src/core/lib/gpr/log_linux.cc
-+++ b/src/core/lib/gpr/log_linux.cc
-@@ -40,7 +40,7 @@
- #include <time.h>
- #include <unistd.h>
--static long gettid(void) { return syscall(__NR_gettid); }
-+static long sys_gettid(void) { return syscall(__NR_gettid); }
- void gpr_log(const char* file, int line, gpr_log_severity severity,
-              const char* format, ...) {
-@@ -70,7 +70,7 @@ void gpr_default_log(gpr_log_func_args* args) {
-   gpr_timespec now = gpr_now(GPR_CLOCK_REALTIME);
-   struct tm tm;
-   static __thread long tid = 0;
--  if (tid == 0) tid = gettid();
-+  if (tid == 0) tid = sys_gettid();
-   timer = static_cast<time_t>(now.tv_sec);
-   final_slash = strrchr(args->file, '/');
-diff --git a/src/core/lib/gpr/log_posix.cc b/src/core/lib/gpr/log_posix.cc
-index b6edc14ab6b..2f7c6ce3760 100644
---- a/src/core/lib/gpr/log_posix.cc
-+++ b/src/core/lib/gpr/log_posix.cc
-@@ -31,7 +31,7 @@
- #include <string.h>
- #include <time.h>
--static intptr_t gettid(void) { return (intptr_t)pthread_self(); }
-+static intptr_t sys_gettid(void) { return (intptr_t)pthread_self(); }
- void gpr_log(const char* file, int line, gpr_log_severity severity,
-              const char* format, ...) {
-@@ -86,7 +86,7 @@ void gpr_default_log(gpr_log_func_args* args) {
-   char* prefix;
-   gpr_asprintf(&prefix, "%s%s.%09d %7" PRIdPTR " %s:%d]",
-                gpr_log_severity_string(args->severity), time_buffer,
--               (int)(now.tv_nsec), gettid(), display_file, args->line);
-+               (int)(now.tv_nsec), sys_gettid(), display_file, args->line);
-   fprintf(stderr, "%-70s %s\n", prefix, args->message);
-   gpr_free(prefix);
-diff --git a/src/core/lib/iomgr/ev_epollex_linux.cc b/src/core/lib/iomgr/ev_epollex_linux.cc
-index 08116b3ab53..76f59844312 100644
---- a/src/core/lib/iomgr/ev_epollex_linux.cc
-+++ b/src/core/lib/iomgr/ev_epollex_linux.cc
-@@ -1102,7 +1102,7 @@ static void end_worker(grpc_pollset* pollset, grpc_pollset_worker* worker,
- }
- #ifndef NDEBUG
--static long gettid(void) { return syscall(__NR_gettid); }
-+static long sys_gettid(void) { return syscall(__NR_gettid); }
- #endif
- /* pollset->mu lock must be held by the caller before calling this.
-@@ -1122,7 +1122,7 @@ static grpc_error* pollset_work(grpc_pollset* pollset,
- #define WORKER_PTR (&worker)
- #endif
- #ifndef NDEBUG
--  WORKER_PTR->originator = gettid();
-+  WORKER_PTR->originator = sys_gettid();
- #endif
-   if (GRPC_TRACE_FLAG_ENABLED(grpc_polling_trace)) {
-     gpr_log(GPR_INFO,
diff --git a/dev-python/grpcio/grpcio-1.22.1.ebuild b/dev-python/grpcio/grpcio-1.22.1.ebuild
deleted file mode 100644 (file)
index 122183c..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="High-performance RPC framework (python libraries)"
-HOMEPAGE="https://grpc.io"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-
-RDEPEND=">=dev-libs/openssl-1.0.2:0=[-bindist]
-       >=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
-       dev-python/protobuf-python[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       net-dns/c-ares:=
-       !<net-libs/grpc-1.16.0[python]
-       sys-libs/zlib:=
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-PATCHES=( "${FILESDIR}/grpc-1.22.1-glibc-2.30-compat.patch" )
-
-python_configure_all() {
-       export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
-       export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
-       export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
-       export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
-       export GRPC_PYTHON_BUILD_WITH_CYTHON=1
-       export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
-}
diff --git a/dev-python/grpcio/grpcio-1.23.0.ebuild b/dev-python/grpcio/grpcio-1.23.0.ebuild
deleted file mode 100644 (file)
index 122183c..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="High-performance RPC framework (python libraries)"
-HOMEPAGE="https://grpc.io"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-
-RDEPEND=">=dev-libs/openssl-1.0.2:0=[-bindist]
-       >=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
-       dev-python/protobuf-python[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       net-dns/c-ares:=
-       !<net-libs/grpc-1.16.0[python]
-       sys-libs/zlib:=
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-PATCHES=( "${FILESDIR}/grpc-1.22.1-glibc-2.30-compat.patch" )
-
-python_configure_all() {
-       export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
-       export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
-       export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
-       export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
-       export GRPC_PYTHON_BUILD_WITH_CYTHON=1
-       export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
-}
diff --git a/dev-python/grpcio/grpcio-1.24.3.ebuild b/dev-python/grpcio/grpcio-1.24.3.ebuild
deleted file mode 100644 (file)
index 0d4dc18..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="High-performance RPC framework (python libraries)"
-HOMEPAGE="https://grpc.io"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-
-RDEPEND=">=dev-libs/openssl-1.0.2:0=[-bindist]
-       >=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
-       dev-python/protobuf-python[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       net-dns/c-ares:=
-       !<net-libs/grpc-1.16.0[python]
-       sys-libs/zlib:=
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-python_configure_all() {
-       export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
-       export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
-       export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
-       export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
-       export GRPC_PYTHON_BUILD_WITH_CYTHON=1
-       export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
-}