media-libs/libirman: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 17:31:04 +0000 (18:31 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 17:31:04 +0000 (18:31 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-libs/libirman/libirman-0.4.5.ebuild

index 5dddb2d838494933af101312b1ccc97c45b736fb..f8f4a774babb49ec6d53ad6560e626f1b8ec9111 100644 (file)
@@ -1,30 +1,35 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils eutils toolchain-funcs
+inherit autotools toolchain-funcs
 
 DESCRIPTION="library for Irman control of Unix software"
 HOMEPAGE="http://www.lirc.org/software/snapshots/"
 SRC_URI="http://www.lirc.org/software/snapshots/${P}.tar.bz2"
 
-SLOT="0"
 LICENSE="GPL-2 LGPL-2"
+SLOT="0"
 KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="static-libs"
-
-DOCS=( TECHNICAL NEWS README TODO )
 
 src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
        tc-export CC LD AR RANLIB
-       autotools-utils_src_prepare
+       econf --disable-static
 }
 
 src_install() {
-       autotools-utils_src_install LIRC_DRIVER_DEVICE="${D}/dev/lirc"
+       export LIRC_DRIVER_DEVICE="${ED}/dev/lirc"
+       default
+       dodoc TECHNICAL
+
+       dobin test_{func,io,name}
 
-       dobin ${AUTOTOOLS_BUILD_DIR}/test_{func,io,name}
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }