version bump for 2.2 and 2.3 branches
authorMarius Mauch <genone@gentoo.org>
Sun, 18 Jun 2006 10:43:43 +0000 (10:43 +0000)
committerMarius Mauch <genone@gentoo.org>
Sun, 18 Jun 2006 10:43:43 +0000 (10:43 +0000)
Package-Manager: portage-2.1

mail-client/sylpheed-claws/ChangeLog
mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.2.3 [new file with mode: 0644]
mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.3.0 [new file with mode: 0644]
mail-client/sylpheed-claws/sylpheed-claws-2.2.3.ebuild [new file with mode: 0644]
mail-client/sylpheed-claws/sylpheed-claws-2.3.0.ebuild [new file with mode: 0644]

index b61cd14cacf04f5dcb57163d319b163b5033f7ef..2a2f15cc73d78e4998ff58e40abef573e23050a9 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for mail-client/sylpheed-claws
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/ChangeLog,v 1.95 2006/06/05 18:25:43 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/ChangeLog,v 1.96 2006/06/18 10:43:43 genone Exp $
+
+*sylpheed-claws-2.3.0 (18 Jun 2006)
+*sylpheed-claws-2.2.3 (18 Jun 2006)
+
+  18 Jun 2006; Marius Mauch <genone@gentoo.org>
+  -sylpheed-claws-2.2.0.ebuild, +sylpheed-claws-2.2.3.ebuild,
+  -sylpheed-claws-2.3.0_rc3.ebuild, +sylpheed-claws-2.3.0.ebuild:
+  Version bump for 2.2 and 2.3 branches.
 
   05 Jun 2006; Simon Stelling <blubb@gentoo.org>
   sylpheed-claws-2.0.0.ebuild:
diff --git a/mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.2.3 b/mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.2.3
new file mode 100644 (file)
index 0000000..44d1217
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 870eb4de8dc242f16171145d8af725b9 sylpheed-claws-2.2.3.tar.bz2 4642651
+RMD160 2d7717a5f4c53230dacec6208b6fc442d69e526d sylpheed-claws-2.2.3.tar.bz2 4642651
+SHA256 a35a679bb9c5e072a65db42092742758c8f5da9cf7f00d45105c065599480f5c sylpheed-claws-2.2.3.tar.bz2 4642651
diff --git a/mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.3.0 b/mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.3.0
new file mode 100644 (file)
index 0000000..37c0853
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 a59b1f1736e89918c648794c94120a8e sylpheed-claws-2.3.0.tar.bz2 4432347
+RMD160 5fa90da6b362f41421b8b5bc72076dec7635c86e sylpheed-claws-2.3.0.tar.bz2 4432347
+SHA256 af3f9bc9150caaf6ef82d6dc6e5ab9d5091822af10f4e539091a2ca9c60dd775 sylpheed-claws-2.3.0.tar.bz2 4432347
diff --git a/mail-client/sylpheed-claws/sylpheed-claws-2.2.3.ebuild b/mail-client/sylpheed-claws/sylpheed-claws-2.2.3.ebuild
new file mode 100644 (file)
index 0000000..f21be6b
--- /dev/null
@@ -0,0 +1,147 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/sylpheed-claws-2.2.3.ebuild,v 1.1 2006/06/18 10:43:43 genone Exp $
+
+IUSE="gnome dillo crypt spell ssl ldap ipv6 pda clamav xface kde imap spamassassin doc startup-notification"
+
+inherit eutils
+
+DESCRIPTION="Bleeding edge version of Sylpheed"
+HOMEPAGE="http://claws.sylpheed.org"
+
+if [ -n "${P/*_rc*/}" ]; then
+       SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+else
+       MY_P="${P/_/-}"
+       S="${WORKDIR}/${MY_P}"
+       SRC_URI="http://claws.sylpheed.org/snapshots/${MY_P}.tar.bz2"
+fi
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+COMMONDEPEND=">=x11-libs/gtk+-2.4
+       pda? ( >=app-pda/jpilot-0.99 )
+       ssl? ( >=dev-libs/openssl-0.9.7 )
+       ldap? ( >=net-nds/openldap-2.0.7 )
+       crypt? ( >=app-crypt/gpgme-0.4 )
+       dillo? ( www-client/dillo )
+       spell? ( virtual/aspell-dict )
+       clamav? ( app-antivirus/clamav )
+       kde? ( kde-base/kdelibs )
+       imap? ( >=net-libs/libetpan-0.45 )
+       gnome? ( >=gnome-base/libgnomeprintui-2.2 )
+       startup-notification? ( x11-libs/startup-notification )
+       !mail-client/sylpheed-claws-pgpinline"  # included in the main package now
+
+DEPEND="${COMMONDEPEND}
+       xface? ( >=media-libs/compface-1.4 )
+       >=sys-apps/sed-4"
+
+RDEPEND="${COMMONDEPEND}
+       app-misc/mime-types
+       net-mail/metamail
+       x11-misc/shared-mime-info"
+
+PROVIDE="virtual/sylpheed"
+
+PLUGIN_NAMES="acpi-notifier att-remover cachesaver etpan-privacy fetchinfo gtkhtml maildir mailmbox newmail notification perl rssyl smime synce vcalendar"
+
+src_compile() {
+       local myconf
+
+       # Optional features
+       myconf="${myconf} `use_enable gnome gnomeprint`"
+       myconf="${myconf} `use_enable imap libetpan`"
+       myconf="${myconf} `use_enable ipv6`"
+       myconf="${myconf} `use_enable ldap`"
+       myconf="${myconf} `use_enable pda jpilot`"
+       myconf="${myconf} `use_enable spell aspell`"
+       myconf="${myconf} `use_enable ssl openssl`"
+       myconf="${myconf} `use_enable xface compface`"
+       myconf="${myconf} `use_enable doc manual`"
+       myconf="${myconf} `use_enable startup-notification`"
+
+       # Optional plugins
+       myconf="${myconf} `use_enable clamav clamav-plugin`"
+       myconf="${myconf} `use_enable crypt pgpmime-plugin`"
+       myconf="${myconf} `use_enable crypt pgpinline-plugin`"
+       myconf="${myconf} `use_enable crypt pgpcore-plugin`"
+       myconf="${myconf} `use_enable dillo dillo-viewer-plugin`"
+       myconf="${myconf} `use_enable spamassassin spamassassin-plugin`"
+
+       econf \
+               --enable-trayicon-plugin \
+               ${myconf} || die "./configure failed"
+
+       emake || die
+}
+
+src_install() {
+       make DESTDIR=${D} install || die
+
+       # wait for upstream: move manpage
+       mv ${D}/usr/share/man/man1/sylpheed{,-claws}.1
+
+       if [ -d ${D}/usr/share/gnome ]; then
+               dodir /usr/share/applications
+               mv ${D}/usr/share/{gnome/apps/Internet,applications}/sylpheed-claws.desktop
+               rm -rf ${D}/usr/share/gnome
+       fi
+
+       # Makefile install sylpheed-claws.png in /usr/share/icons/hicolor/48x48/apps
+       # => also install it in /usr/share/pixmaps for other desktop envs
+       # => also install higher resolution icons in /usr/share/icons/hicolor/...
+       insinto /usr/share/pixmaps
+       doins sylpheed-claws.png
+       local res resdir
+       for res in 64x64 128x128 ; do
+               resdir="/usr/share/icons/hicolor/${res}/apps"
+               insinto ${resdir}
+               newins sylpheed-claws-${res}.png sylpheed-claws.png
+       done
+
+       dodoc AUTHORS ChangeLog* INSTALL* NEWS README* TODO*
+       docinto tools
+       dodoc tools/README*
+
+       # install the extra tools
+       cd ${S}/tools
+       exeinto /usr/lib/${PN}/tools
+       doexe *.pl *.py *.rc *.conf *.sh
+       doexe tb2sylpheed update-po uudec
+
+       if use kde; then
+               local kdeprefix="$(kde-config --prefix)"
+               local servicescript="sylpheed-kdeservicemenu.pl"
+               cd ${S}/tools/kdeservicemenu
+               for f in sylpheed-attach-files.desktop sylpheed-compress-attach.desktop; do
+                       sed -e "s:SCRIPT_PATH:${kdeprefix}/bin/${servicescript}:g" template_$f > $f
+                       install -m 0644 $f ${D}/${kdeprefix}/share/apps/konqueror/servicemenus/$f
+               done
+               insinto ${kdeprefix}/bin
+               doexe ${servicescript}
+       fi
+
+       # kill useless plugin files
+       rm -f ${D}/usr/lib*/${PN}/plugins/*.{la,a}
+}
+
+pkg_postinst() {
+       UPDATE_PLUGINS=""
+       for x in ${PLUGIN_NAMES}; do
+               has_version mail-client/sylpheed-claws-$x && UPDATE_PLUGINS="${UPDATE_PLUGINS} $x"
+       done
+       if [ -n "${UPDATE_PLUGINS}" ]; then
+               ewarn
+               ewarn "You have to re-emerge or update the following plugins:"
+               ewarn
+               for x in ${UPDATE_PLUGINS}; do
+                       ewarn "    mail-client/sylpheed-claws-$x"
+               done
+               ewarn
+               epause 5
+               ebeep 3
+       fi
+}
diff --git a/mail-client/sylpheed-claws/sylpheed-claws-2.3.0.ebuild b/mail-client/sylpheed-claws/sylpheed-claws-2.3.0.ebuild
new file mode 100644 (file)
index 0000000..d9b237e
--- /dev/null
@@ -0,0 +1,144 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/sylpheed-claws-2.3.0.ebuild,v 1.1 2006/06/18 10:43:43 genone Exp $
+
+IUSE="gnome dillo crypt spell ssl ldap ipv6 pda clamav xface kde imap spamassassin doc startup-notification"
+
+inherit eutils
+
+DESCRIPTION="Bleeding edge version of Sylpheed"
+HOMEPAGE="http://claws.sylpheed.org"
+
+if [ -n "${P/*_rc*/}" ]; then
+       SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+else
+       MY_P="${P/_/-}"
+       S="${WORKDIR}/${MY_P}"
+       SRC_URI="http://claws.sylpheed.org/snapshots/${MY_P}.tar.bz2"
+fi
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+COMMONDEPEND=">=x11-libs/gtk+-2.4
+       pda? ( >=app-pda/jpilot-0.99 )
+       ssl? ( >=dev-libs/openssl-0.9.7 )
+       ldap? ( >=net-nds/openldap-2.0.7 )
+       crypt? ( >=app-crypt/gpgme-0.4 )
+       dillo? ( www-client/dillo )
+       spell? ( virtual/aspell-dict )
+       clamav? ( app-antivirus/clamav )
+       kde? ( kde-base/kdelibs )
+       imap? ( >=net-libs/libetpan-0.45 )
+       gnome? ( >=gnome-base/libgnomeprintui-2.2 )
+       startup-notification? ( x11-libs/startup-notification )
+       !mail-client/sylpheed-claws-pgpinline"  # included in the main package now
+
+DEPEND="${COMMONDEPEND}
+       xface? ( >=media-libs/compface-1.4 )
+       >=sys-apps/sed-4"
+
+RDEPEND="${COMMONDEPEND}
+       app-misc/mime-types
+       net-mail/metamail
+       x11-misc/shared-mime-info"
+
+PROVIDE="virtual/sylpheed"
+
+PLUGIN_NAMES="acpi-notifier att-remover cachesaver etpan-privacy fetchinfo gtkhtml maildir mailmbox newmail notification perl rssyl smime synce vcalendar"
+
+src_compile() {
+       local myconf
+
+       # Optional features
+       myconf="${myconf} `use_enable gnome gnomeprint`"
+       myconf="${myconf} `use_enable imap libetpan`"
+       myconf="${myconf} `use_enable ipv6`"
+       myconf="${myconf} `use_enable ldap`"
+       myconf="${myconf} `use_enable pda jpilot`"
+       myconf="${myconf} `use_enable spell aspell`"
+       myconf="${myconf} `use_enable ssl openssl`"
+       myconf="${myconf} `use_enable xface compface`"
+       myconf="${myconf} `use_enable doc manual`"
+       myconf="${myconf} `use_enable startup-notification`"
+
+       # Optional plugins
+       myconf="${myconf} `use_enable clamav clamav-plugin`"
+       myconf="${myconf} `use_enable crypt pgpmime-plugin`"
+       myconf="${myconf} `use_enable crypt pgpinline-plugin`"
+       myconf="${myconf} `use_enable crypt pgpcore-plugin`"
+       myconf="${myconf} `use_enable dillo dillo-viewer-plugin`"
+       myconf="${myconf} `use_enable spamassassin spamassassin-plugin`"
+
+       econf \
+               --enable-trayicon-plugin \
+               ${myconf} || die "./configure failed"
+
+       emake || die
+}
+
+src_install() {
+       make DESTDIR=${D} install || die
+
+       if [ -d ${D}/usr/share/gnome ]; then
+               dodir /usr/share/applications
+               mv ${D}/usr/share/{gnome/apps/Internet,applications}/sylpheed-claws.desktop
+               rm -rf ${D}/usr/share/gnome
+       fi
+
+       # Makefile install sylpheed-claws.png in /usr/share/icons/hicolor/48x48/apps
+       # => also install it in /usr/share/pixmaps for other desktop envs
+       # => also install higher resolution icons in /usr/share/icons/hicolor/...
+       insinto /usr/share/pixmaps
+       doins sylpheed-claws.png
+       local res resdir
+       for res in 64x64 128x128 ; do
+               resdir="/usr/share/icons/hicolor/${res}/apps"
+               insinto ${resdir}
+               newins sylpheed-claws-${res}.png sylpheed-claws.png
+       done
+
+       dodoc AUTHORS ChangeLog* INSTALL* NEWS README* TODO*
+       docinto tools
+       dodoc tools/README*
+
+       # install the extra tools
+       cd ${S}/tools
+       exeinto /usr/lib/${PN}/tools
+       doexe *.pl *.py *.rc *.conf *.sh
+       doexe tb2sylpheed update-po uudec
+
+       if use kde; then
+               local kdeprefix="$(kde-config --prefix)"
+               local servicescript="sylpheed-kdeservicemenu.pl"
+               cd ${S}/tools/kdeservicemenu
+               for f in sylpheed-attach-files.desktop sylpheed-compress-attach.desktop; do
+                       sed -e "s:SCRIPT_PATH:${kdeprefix}/bin/${servicescript}:g" template_$f > $f
+                       install -m 0644 $f ${D}/${kdeprefix}/share/apps/konqueror/servicemenus/$f
+               done
+               insinto ${kdeprefix}/bin
+               doexe ${servicescript}
+       fi
+
+       # kill useless plugin files
+       rm -f ${D}/usr/lib*/${PN}/plugins/*.{la,a}
+}
+
+pkg_postinst() {
+       UPDATE_PLUGINS=""
+       for x in ${PLUGIN_NAMES}; do
+               has_version mail-client/sylpheed-claws-$x && UPDATE_PLUGINS="${UPDATE_PLUGINS} $x"
+       done
+       if [ -n "${UPDATE_PLUGINS}" ]; then
+               ewarn
+               ewarn "You have to re-emerge or update the following plugins:"
+               ewarn
+               for x in ${UPDATE_PLUGINS}; do
+                       ewarn "    mail-client/sylpheed-claws-$x"
+               done
+               ewarn
+               epause 5
+               ebeep 3
+       fi
+}