app-i18n/tomoe-gtk: Drop USE python
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 30 Apr 2020 10:56:23 +0000 (12:56 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 30 Apr 2020 18:18:16 +0000 (20:18 +0200)
Bug: https://bugs.gentoo.org/695012
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r6.ebuild [new file with mode: 0644]

diff --git a/app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r6.ebuild b/app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r6.ebuild
new file mode 100644 (file)
index 0000000..d5d63f1
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Tomoe GTK+ interface widget library"
+HOMEPAGE="http://tomoe.osdn.jp/"
+SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+RDEPEND="app-i18n/tomoe
+       x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+       dev-util/gtk-doc-am
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+src_configure() {
+       econf \
+               $(use_enable static-libs static) \
+               --without-python \
+               --without-gucharmap
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -type f -delete || die
+}