sci-libs/tnt: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 17:40:35 +0000 (18:40 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 17:40:35 +0000 (18:40 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
sci-libs/tnt/tnt-3.0.12.ebuild

index 2a622ddfa0c28d16fd193d51c52b17ace8f1a68f..9de7e6dca2ee1c9866feb48fd65cb12941d539e7 100644 (file)
@@ -1,28 +1,22 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
-inherit versionator
-
-MYP="${PN}_$(replace_all_version_separators '_')"
+MY_P="${PN}_$(ver_rs 1-3 '_')"
 
 DESCRIPTION="Template Numerical Toolkit: C++ headers for array and matrices"
 HOMEPAGE="http://math.nist.gov/tnt/"
-SRC_URI="http://math.nist.gov/tnt/${MYP}.zip"
+SRC_URI="http://math.nist.gov/tnt/${MY_P}.zip"
 
 LICENSE="public-domain"
 SLOT="0"
 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
 
-IUSE=""
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
+BDEPEND="app-arch/unzip"
 
 S="${WORKDIR}/${PN}"
 
 src_install() {
-       insinto /usr/include
-       doins *.h
+       doheader *.h
 }