- Initial import. Original ebuild by Priit Laes, modifications by Björn Ruberg and...
authorYuri Vasilevski <yvasilev@gentoo.org>
Mon, 13 Mar 2006 00:04:43 +0000 (00:04 +0000)
committerYuri Vasilevski <yvasilev@gentoo.org>
Mon, 13 Mar 2006 00:04:43 +0000 (00:04 +0000)
Package-Manager: portage-2.1_pre6

x11-wm/matchbox-desktop/ChangeLog [new file with mode: 0644]
x11-wm/matchbox-desktop/Manifest [new file with mode: 0644]
x11-wm/matchbox-desktop/files/digest-matchbox-desktop-0.9.1 [new file with mode: 0644]
x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild [new file with mode: 0644]
x11-wm/matchbox-desktop/metadata.xml [new file with mode: 0644]
x11-wm/matchbox-panel/ChangeLog [new file with mode: 0644]
x11-wm/matchbox-panel/Manifest [new file with mode: 0644]
x11-wm/matchbox-panel/files/digest-matchbox-panel-0.9.2 [new file with mode: 0644]
x11-wm/matchbox-panel/matchbox-panel-0.9.2.ebuild [new file with mode: 0644]
x11-wm/matchbox-panel/metadata.xml [new file with mode: 0644]

diff --git a/x11-wm/matchbox-desktop/ChangeLog b/x11-wm/matchbox-desktop/ChangeLog
new file mode 100644 (file)
index 0000000..0e134f5
--- /dev/null
@@ -0,0 +1,11 @@
+# ChangeLog for x11-wm/matchbox-desktop
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-desktop/ChangeLog,v 1.1 2006/03/13 00:00:52 yvasilev Exp $
+
+*matchbox-desktop-0.9.1 (12 Mar 2006)
+
+  12 Mar 2006; <yvasilev@gentoo.org> +metadata.xml,
+  +matchbox-desktop-0.9.1.ebuild:
+  - Initial import. Original ebuild by Priit Laes, modifications by Björn
+  Ruberg and Yuri Vasilevski.
+
diff --git a/x11-wm/matchbox-desktop/Manifest b/x11-wm/matchbox-desktop/Manifest
new file mode 100644 (file)
index 0000000..70c492a
--- /dev/null
@@ -0,0 +1,12 @@
+MD5 4a5fdfb28e59872bc8321d196e4ceb74 ChangeLog 322
+RMD160 12545b5286fe242647949d90898c673133d69251 ChangeLog 322
+SHA256 6afbe73588c2c7d2c94231e9b9db7b8d49d84359695b90c8e5002e71374dd65c ChangeLog 322
+MD5 4c02b86d2b1a220bba02b11404402683 files/digest-matchbox-desktop-0.9.1 271
+RMD160 40dc6dff615bbdeccb223be54e427ab06d932b7a files/digest-matchbox-desktop-0.9.1 271
+SHA256 55deafad37f8bd6598dabd6da4be1eb3ce1284f09fe557d13409eab3a13b296f files/digest-matchbox-desktop-0.9.1 271
+MD5 d468bf60a4acf27d57a18c20e97b63f7 matchbox-desktop-0.9.1.ebuild 853
+RMD160 b08099a81f7185ba433bf2e0bd153a8000a99833 matchbox-desktop-0.9.1.ebuild 853
+SHA256 13e7029a53115ac1a2325c1f1111f177aca6173c6de05c1f0d18d4b77c8efe4c matchbox-desktop-0.9.1.ebuild 853
+MD5 a80bc50cf196a9e5a2764d6f6081b56a metadata.xml 247
+RMD160 49e7f36b66be574d7f3341589ebff702e1c8c8a9 metadata.xml 247
+SHA256 5270fc293d10727efe22af7c71da351586b63251d10bbadd916060e405d88ce9 metadata.xml 247
diff --git a/x11-wm/matchbox-desktop/files/digest-matchbox-desktop-0.9.1 b/x11-wm/matchbox-desktop/files/digest-matchbox-desktop-0.9.1
new file mode 100644 (file)
index 0000000..20b48f4
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 3335a30b1a1aacfb39f23b505254765c matchbox-desktop-0.9.1.tar.bz2 231962
+RMD160 75a2368a261e44b1734bcdb3efd278da479a35af matchbox-desktop-0.9.1.tar.bz2 231962
+SHA256 ecb025d3660d80a9850973111b4fdfffaa50b47cbf0c5467b508d28d65146793 matchbox-desktop-0.9.1.tar.bz2 231962
diff --git a/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild b/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild
new file mode 100644 (file)
index 0000000..056ee20
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 2006-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild,v 1.1 2006/03/13 00:00:52 yvasilev Exp $
+
+inherit versionator
+
+DESCRIPTION="The Matchbox Desktop"
+HOMEPAGE="http://projects.o-hand.com/matchbox/"
+SRC_URI="http://projects.o-hand.com/matchbox/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="debug dnotify startup-notification"
+
+DEPEND=">=x11-libs/libmatchbox-1.5
+       startup-notification? ( x11-libs/startup-notification )"
+
+RDEPEND="${DEPEND}
+       x11-wm/matchbox-common"
+
+src_compile() {
+       econf   $(use_enable debug) \
+               $(use_enable startup-notification) \
+               $(use_enable dnotify) \
+               || die "Configuration failed"
+
+       emake || die "Compilation failed"
+}
+
+src_install() {
+       make DESTDIR=${D} install || die "Installation failed"
+
+       dodoc AUTHORS ChangeLog INSTALL NEWS README
+}
diff --git a/x11-wm/matchbox-desktop/metadata.xml b/x11-wm/matchbox-desktop/metadata.xml
new file mode 100644 (file)
index 0000000..a7160ed
--- /dev/null
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gpe</herd>
+<maintainer>
+<email>yvasilev@gentoo.org</email>
+<name>Yuri Vasilevski</name>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-wm/matchbox-panel/ChangeLog b/x11-wm/matchbox-panel/ChangeLog
new file mode 100644 (file)
index 0000000..4516a66
--- /dev/null
@@ -0,0 +1,11 @@
+# ChangeLog for x11-wm/matchbox-panel
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-panel/ChangeLog,v 1.1 2006/03/13 00:04:43 yvasilev Exp $
+
+*matchbox-panel-0.9.2 (13 Mar 2006)
+
+  13 Mar 2006; <yvasilev@gentoo.org> +metadata.xml,
+  +matchbox-panel-0.9.2.ebuild:
+  - Initial import. Original ebuild by Priit Laes, modifications by Björn
+  Ruberg and Yuri Vasilevski.
+
diff --git a/x11-wm/matchbox-panel/Manifest b/x11-wm/matchbox-panel/Manifest
new file mode 100644 (file)
index 0000000..a63e9ac
--- /dev/null
@@ -0,0 +1,12 @@
+MD5 c0350d3ee356f5813f371616c3d774ce ChangeLog 318
+RMD160 0e188a2c05393fcc48832979ab1576ca8e45c341 ChangeLog 318
+SHA256 3d5be5cd9449e4b30f0f6c0e18a5e8905c660659c047fb28903e73f025a78ccf ChangeLog 318
+MD5 ff25695b2513bcdbc8771cd0cd169e9e files/digest-matchbox-panel-0.9.2 265
+RMD160 2f42416bc05c7e6fef0f55e9dd640dde3c3f56a3 files/digest-matchbox-panel-0.9.2 265
+SHA256 0bf66f68b9c69beed37b33dd5491658bd28fcbf8b1b3c0c24de7d27c02e236d0 files/digest-matchbox-panel-0.9.2 265
+MD5 99ad92504662d3632e7a090dbd4e4bd6 matchbox-panel-0.9.2.ebuild 949
+RMD160 5d5e77d9e0d8301c816119d060b57f9e6950e105 matchbox-panel-0.9.2.ebuild 949
+SHA256 1cd3bda35bc9034353cc54fe3bd832a56c0cdb36ca8f88d3d53cf4a5fe2737e1 matchbox-panel-0.9.2.ebuild 949
+MD5 a80bc50cf196a9e5a2764d6f6081b56a metadata.xml 247
+RMD160 49e7f36b66be574d7f3341589ebff702e1c8c8a9 metadata.xml 247
+SHA256 5270fc293d10727efe22af7c71da351586b63251d10bbadd916060e405d88ce9 metadata.xml 247
diff --git a/x11-wm/matchbox-panel/files/digest-matchbox-panel-0.9.2 b/x11-wm/matchbox-panel/files/digest-matchbox-panel-0.9.2
new file mode 100644 (file)
index 0000000..e323916
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 5b589ef77104e02650d911333cfa9b14 matchbox-panel-0.9.2.tar.bz2 157604
+RMD160 65e5849c04433354cae645af05aff7f6dd9e21e2 matchbox-panel-0.9.2.tar.bz2 157604
+SHA256 efabe0377c7bd2e82a0b9d648be2213bf5a2af0e8e3fa1f059426f9ebcf35c23 matchbox-panel-0.9.2.tar.bz2 157604
diff --git a/x11-wm/matchbox-panel/matchbox-panel-0.9.2.ebuild b/x11-wm/matchbox-panel/matchbox-panel-0.9.2.ebuild
new file mode 100644 (file)
index 0000000..66e0315
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 2006-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-panel/matchbox-panel-0.9.2.ebuild,v 1.1 2006/03/13 00:04:43 yvasilev Exp $
+
+inherit versionator
+
+DESCRIPTION="The Matchbox Panel"
+HOMEPAGE="http://projects.o-hand.com/matchbox/"
+SRC_URI="http://projects.o-hand.com/matchbox/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="debug dnotify lowres nls startup-notification"
+
+DEPEND=">=x11-libs/libmatchbox-1.5
+       startup-notification? ( x11-libs/startup-notification )
+       nls? ( sys-devel/gettext )"
+
+RDEPEND="${DEPEND}
+       x11-wm/matchbox-common"
+
+src_compile() {
+       econf   $(use_enable debug) \
+               $(use_enable nls) \
+               $(use_enable startup-notification) \
+               $(use_enable dnotify) \
+               $(use_enable lowres small-icons) \
+               || die "Configuration failed"
+
+       emake || die "Compilation failed"
+}
+
+src_install() {
+       make DESTDIR=${D} install || die "Installation failed"
+
+       dodoc AUTHORS ChangeLog INSTALL NEWS README
+}
diff --git a/x11-wm/matchbox-panel/metadata.xml b/x11-wm/matchbox-panel/metadata.xml
new file mode 100644 (file)
index 0000000..a7160ed
--- /dev/null
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gpe</herd>
+<maintainer>
+<email>yvasilev@gentoo.org</email>
+<name>Yuri Vasilevski</name>
+</maintainer>
+</pkgmetadata>