Version bump and cleaning up
authorRobert Buchholz <rbu@gentoo.org>
Tue, 2 Jan 2007 03:42:21 +0000 (03:42 +0000)
committerRobert Buchholz <rbu@gentoo.org>
Tue, 2 Jan 2007 03:42:21 +0000 (03:42 +0000)
Package-Manager: portage-2.1.1-r2

app-misc/g15composer/ChangeLog
app-misc/g15composer/files/digest-g15composer-3.1 [new file with mode: 0644]
app-misc/g15composer/files/g15composer-3.0.2.confd [new file with mode: 0644]
app-misc/g15composer/files/g15composer-3.0.2.initd [new file with mode: 0644]
app-misc/g15composer/files/g15composer-3.1.confd [new file with mode: 0644]
app-misc/g15composer/files/g15composer-3.1.initd [new file with mode: 0644]
app-misc/g15composer/g15composer-3.0.2.ebuild
app-misc/g15composer/g15composer-3.1.ebuild [new file with mode: 0644]
app-misc/g15composer/metadata.xml

index a8829028db6fdb26d551f4aeae41cabfbf316ede..bd968860990c3f378930e89ef16cbfa6a5f4c3b3 100644 (file)
@@ -1,6 +1,17 @@
 # ChangeLog for app-misc/g15composer
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15composer/ChangeLog,v 1.9 2006/12/06 19:52:39 jokey Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15composer/ChangeLog,v 1.10 2007/01/02 03:42:21 rbu Exp $
+
+*g15composer-3.1 (02 Jan 2007)
+
+  02 Jan 2007; Robert Buchholz <rbu@gentoo.org>
+  -files/g15composer-2.1.confd, -files/g15composer-2.1.initd,
+  +files/g15composer-3.0.2.confd, +files/g15composer-3.0.2.initd,
+  +files/g15composer-3.1.confd, +files/g15composer-3.1.initd, metadata.xml,
+  -g15composer-2.1-r1.ebuild, -g15composer-3.0.1.ebuild,
+  g15composer-3.0.2.ebuild, +g15composer-3.1.ebuild:
+  Bumping to 3.1, init supports running the composer as user. Removing some
+  old versions.
 
 *g15composer-3.0.2 (06 Dec 2006)
 
diff --git a/app-misc/g15composer/files/digest-g15composer-3.1 b/app-misc/g15composer/files/digest-g15composer-3.1
new file mode 100644 (file)
index 0000000..1381666
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 35a42f393b3ae4a178e237bc170f390d g15composer-3.1.tar.bz2 104109
+RMD160 ab31de24416452a8a363e0a0ae8856c21706b6fc g15composer-3.1.tar.bz2 104109
+SHA256 d8f34c1711e95f8ca3ddd9fd5f557a51bb23b79099fbf2fddb96bdcd03067988 g15composer-3.1.tar.bz2 104109
diff --git a/app-misc/g15composer/files/g15composer-3.0.2.confd b/app-misc/g15composer/files/g15composer-3.0.2.confd
new file mode 100644 (file)
index 0000000..4007480
--- /dev/null
@@ -0,0 +1,8 @@
+# /etc/conf.d/g15composer: Configuration for the g15composer
+
+# The CONTROL_FIFO is the name of the FIFO that g15composer listens to.
+# It does not create a screen on the display, but allows programs to
+# create their own non-virtual screens.
+# Please make sure the file specified does not exist.
+
+CONTROL_FIFO="/var/run/g15composer"
diff --git a/app-misc/g15composer/files/g15composer-3.0.2.initd b/app-misc/g15composer/files/g15composer-3.0.2.initd
new file mode 100644 (file)
index 0000000..b06f64c
--- /dev/null
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15composer/files/g15composer-3.0.2.initd,v 1.1 2007/01/02 03:42:21 rbu Exp $
+
+PIDFILE=/var/run/${SVCNAME}.pid
+
+depend() {
+       need g15daemon
+}
+
+start() {
+       ebegin "Starting ${SVCNAME}"
+       start-stop-daemon --start --background --pidfile ${PIDFILE} --make-pidfile --exec /usr/bin/g15composer -- -b "${CONTROL_FIFO}"
+       chmod 720 "${CONTROL_FIFO}"
+       chgrp users "${CONTROL_FIFO}"
+       eend $?
+}
+
+stop() {
+       ebegin "Stoping ${SVCNAME}"
+       start-stop-daemon --stop --pidfile ${PIDFILE} --name g15composer
+       rm "${CONTROL_FIFO}"
+       eend $?
+}
diff --git a/app-misc/g15composer/files/g15composer-3.1.confd b/app-misc/g15composer/files/g15composer-3.1.confd
new file mode 100644 (file)
index 0000000..f42ab95
--- /dev/null
@@ -0,0 +1,17 @@
+# /etc/conf.d/g15composer: Configuration for the g15composer
+
+# The CONTROL_FIFO is the name of the FIFO that g15composer listens to.
+# It does not create a screen on the display, but allows programs to
+# create their own non-virtual screens.
+# Please make sure the file specified does not exist.
+CONTROL_FIFO="/var/run/g15composer"
+
+# Set the user who owns the CONTROL_FIFO.
+# As this is also the user as whom g15composer is run,
+# it has to be someone who can create further message channels
+# This should be the user who runs the LCD clients
+FIFO_USER=
+
+# Set the grop which owns the CONTROL_FIFO.
+# The users who want to display screens on the LCD need to be in this group.
+FIFO_GROUP=users
diff --git a/app-misc/g15composer/files/g15composer-3.1.initd b/app-misc/g15composer/files/g15composer-3.1.initd
new file mode 100644 (file)
index 0000000..d737131
--- /dev/null
@@ -0,0 +1,49 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15composer/files/g15composer-3.1.initd,v 1.1 2007/01/02 03:42:21 rbu Exp $
+
+PIDFILE=/var/run/${SVCNAME}.pid
+
+depend() {
+       need g15daemon
+}
+
+start() {
+       ebegin "Starting ${SVCNAME}"
+
+       if [ -z "${FIFO_USER}" -o -z "${FIFO_GROUP}" ] ; then
+               eerror "Please set the FIFO_USER and FIFO_GROUP variables in /etc/conf.d/${SVCNAME}"
+               eend 1
+               return 1
+       fi
+       if [ -e "${CONTROL_FIFO}" -a ! -p "${CONTROL_FIFO}" ] ; then
+               eerror "${CONTROL_FIFO} exists and is not a FIFO. Please remove."
+               eend 1
+               return 1
+       fi
+       if [ ! -p "${CONTROL_FIFO}" ] ; then
+               einfo "Creating FIFO at ${CONTROL_FIFO}"
+               mkfifo -m660 "${CONTROL_FIFO}"
+       else
+               einfo "Reusing FIFO at ${CONTROL_FIFO}"
+       fi
+
+       chown ${FIFO_USER} "${CONTROL_FIFO}"
+       chgrp ${FIFO_GROUP} "${CONTROL_FIFO}"
+       start-stop-daemon --start --background --pidfile ${PIDFILE} --make-pidfile --exec \
+               /usr/bin/g15composer -- -b -u "${FIFO_USER}" -g "${FIFO_GROUP}" "${CONTROL_FIFO}"
+       eend $?
+}
+
+stop() {
+       ebegin "Stoping ${SVCNAME}"
+       start-stop-daemon --stop --pidfile ${PIDFILE} --name g15composer
+       if [ -p "${CONTROL_FIFO}" ] ; then
+               einfo "Removing FIFO at ${CONTROL_FIFO}"
+               rm -f "${CONTROL_FIFO}"
+       else
+               ewarn "FIFO at ${CONTROL_FIFO} was lost"
+       fi
+       eend $?
+}
index 88e1d5fce3d001dff71a483e605650e3631aa087..94f2a5ae0f1aaaf08f045aee0dfbfcb896dfa3f5 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15composer/g15composer-3.0.2.ebuild,v 1.1 2006/12/06 19:52:39 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15composer/g15composer-3.0.2.ebuild,v 1.2 2007/01/02 03:42:21 rbu Exp $
 
 inherit eutils
 
@@ -40,8 +40,8 @@ src_compile() {
 src_install() {
        emake DESTDIR="${D}" install || die "make install failed"
 
-       newinitd "${FILESDIR}/${PN}-2.1.initd" ${PN}
-       newconfd "${FILESDIR}/${PN}-2.1.confd" ${PN}
+       newinitd "${FILESDIR}/${P}.initd" ${PN}
+       newconfd "${FILESDIR}/${P}.confd" ${PN}
 
        dodoc AUTHORS README ChangeLog
 
diff --git a/app-misc/g15composer/g15composer-3.1.ebuild b/app-misc/g15composer/g15composer-3.1.ebuild
new file mode 100644 (file)
index 0000000..70b0b9e
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15composer/g15composer-3.1.ebuild,v 1.1 2007/01/02 03:42:21 rbu Exp $
+
+inherit eutils
+
+DESCRIPTION="A library to render text and shapes into a buffer usable by the Logitech G15 keyboard"
+HOMEPAGE="http://g15tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/g15tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="amarok truetype examples"
+
+DEPEND="app-misc/g15daemon
+       >=dev-libs/libg15render-1.2
+       truetype? ( media-libs/freetype )
+       amarok? ( kde-base/kdelibs )"
+
+RDEPEND="${DEPEND}
+       amarok? ( dev-perl/DCOP-Amarok-Player )"
+
+pkg_setup() {
+       if use amarok && ! built_with_use dev-lang/perl ithreads ; then
+               echo
+               eerror "dev-lang/perl must be built with USE=\"ithreads\" for the Amarok display to work."
+               die
+       fi
+}
+
+src_compile() {
+       econf \
+               $(use_enable truetype ttf ) \
+               || die "configure failed"
+
+       emake || die "make failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "make install failed"
+
+       newinitd "${FILESDIR}/${P}.initd" ${PN}
+       newconfd "${FILESDIR}/${P}.confd" ${PN}
+
+       dodoc AUTHORS README ChangeLog
+
+       if use examples ; then
+               exeinto "${ROOT}/usr/share/${PN}"
+               doexe examples/*
+       fi
+
+       if use amarok ; then
+               exeinto "${ROOT}/usr/share/apps/amarok/scripts"
+               newexe examples/amarok-g15-perl.pl g15-display.pl
+       fi
+}
+
+pkg_postinst() {
+       einfo "Set the user to run g15composer in /etc/conf.d/g15composer before starting the service."
+
+       if use amarok; then
+               echo
+               einfo "g15-display.pl was installed into your Amarok script directory."
+               einfo "To start it, have a look at Tools -> Script Manager in the Amarok menu."
+       fi
+}
index dce4644a99be47dac22e07093e8bcdf71c2240fe..ad12036a061b21d23224eb132f8ff95407c331c2 100644 (file)
@@ -3,7 +3,7 @@
 <pkgmetadata>
        <herd>lcd</herd>
        <maintainer>
-               <email>rob@thetruth.de</email>
+               <email>rbu@gentoo.org</email>
                <name>Robert Buchholz</name>
        </maintainer>
 </pkgmetadata>