app-metrics/collectd: add slurm plugin
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 30 Apr 2020 11:58:16 +0000 (13:58 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 30 Apr 2020 14:10:16 +0000 (16:10 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
app-metrics/collectd/collectd-5.11.0.ebuild
profiles/arch/amd64/package.use.mask
profiles/arch/base/package.use.mask
profiles/arch/x86/package.use.mask
profiles/desc/collectd_plugins.desc

index 9b6e85c0ec72aaba80d67424713dbaa5a8baa1b9..06b81f9ad03b50958ab8dbc99e8a96608420dcd7 100644 (file)
@@ -37,6 +37,7 @@ IUSE="contrib debug java kernel_Darwin kernel_FreeBSD kernel_linux perl selinux
 # netapp:         Requires libnetapp (http://communities.netapp.com/docs/DOC-1110)
 # pf:             Requires BSD packet filter
 # pinba:          Requires MySQL Pinba engine (http://pinba.org/)
+# redfish:        Requires libredfish
 # tape:           Requires libkstat (Solaris only)
 # tokyotyrant:    Requires tokyotyrant
 # write_riemann:  Requires riemann-c-client
@@ -44,7 +45,7 @@ IUSE="contrib debug java kernel_Darwin kernel_FreeBSD kernel_linux perl selinux
 # zone:           Solaris only...
 COLLECTD_IMPOSSIBLE_PLUGINS="apple_sensors amqp1 aquaero barometer
        dpdkevents dpdkstat dpdk_telemetry grpc intel_pmu intel_rdt lpar
-       mic netapp pf pinba tape tokyotyrant write_riemann xmms zone"
+       mic netapp pf pinba redfish tape tokyotyrant write_riemann xmms zone"
 
 # Plugins that have been (compile) tested and can be enabled via COLLECTD_PLUGINS
 COLLECTD_TESTED_PLUGINS="aggregation amqp apache apcups ascent battery bind
@@ -58,8 +59,8 @@ COLLECTD_TESTED_PLUGINS="aggregation amqp apache apcups ascent battery bind
        network network nfs nginx notify_desktop notify_email notify_nagios
        ntpd numa nut olsrd onewire openldap openvpn oracle ovs_events
        ovs_stats perl ping postgresql powerdns processes protocols python
-       python redis routeros rrdcached rrdtool sensors serial sigrok smart
-       snmp snmp_agent statsd swap sysevent syslog table tail tail_csv
+       python redis routeros rrdcached rrdtool sensors serial sigrok slurm
+       smart snmp snmp_agent statsd swap sysevent syslog table tail tail_csv
        target_notification target_replace target_scale target_set tcpconns
        teamspeak2 ted thermal threshold turbostat unixsock
        uptime users uuid varnish virt vmem vserver wireless write_graphite
@@ -124,7 +125,7 @@ COMMON_DEPEND="
        collectd_plugins_rrdtool?               ( net-analyzer/rrdtool:= )
        collectd_plugins_sensors?               ( sys-apps/lm-sensors:= )
        collectd_plugins_sigrok?                ( <sci-libs/libsigrok-0.4:= dev-libs/glib:2 )
-       collectd_plugins_smart?                 ( dev-libs/libatasmart )
+       collectd_plugins_slurm?                 ( sys-cluster/slurm )
        collectd_plugins_snmp?                  ( net-analyzer/net-snmp )
        collectd_plugins_snmp_agent?            ( net-analyzer/net-snmp )
        collectd_plugins_sysevent?              ( dev-libs/yajl:= )
index 844b2b43071f927df97185736d71783ac4c1fb0f..0555bad5aaac8b2592706d42aa8817efb154c8b0 100644 (file)
 
 #--- END OF EXAMPLES ---
 
+# Thomas Deutschmann <whissi@gentoo.org> (2020-04-30)
+# sys-cluster/slurm is keyworded on amd64
+app-metrics/collectd -collectd_plugins_slurm
+
 # Georgy Yakovlev <gyakovlev@gentoo.org (2020-04-26)
 # static-pie works on amd64, #719444
 sys-libs/glibc -static-pie
index 281b7ebbb183725b2ea7a85ddf39f0e97d7e094b..c9b37b2a7957a0a33789248e60fae66445abd185 100644 (file)
@@ -1,6 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
+# Thomas Deutschmann <whissi@gentoo.org> (2020-04-30)
+# Dependency is only keyworded on amd64 and x86
+app-metrics/collectd collectd_plugins_slurm
+
 # Georgy Yakovlev <gyakovlev@gentoo.org> (2020-04-26)
 # static-pie is not implemented on all arches, #719444
 # https://sourceware.org/glibc/wiki/PortStatus
index b9f6b333ae7812bb2e7e049b11b16d9ff999e515..caea569f2bf58ab3c503a9b3c7de727af1eb8f48 100644 (file)
@@ -1,6 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
+# Thomas Deutschmann <whissi@gentoo.org> (2020-04-30)
+# sys-cluster/slurm is keyworded on x86
+app-metrics/collectd -collectd_plugins_slurm
+
 # Georgy Yakovlev <gyakovlev@gentoo.org (2020-04-26)
 # static-pie works on x86, #719444
 sys-libs/glibc -static-pie
index e997f46d1aa665045a22812cca56c173dfa52cc0..6b779a43a168272ad89dd6672bd257eef9fe8d14 100644 (file)
@@ -101,6 +101,7 @@ rrdtool - Build the rrdtool output plugin (writes values to RRD-files)
 sensors - Build the sensors input plugin (reads hardware sensors from lm-sensors)
 serial - Build the serial input plugin (collects the traffic on serial interfaces)
 sigrok - Build the sigrok input plugin (reads measurements from any supported hardware from sigrok project)
+slurm - Build the slurm input plugin (collects metrics from the SLURM workload manager)
 smart - Build the S.M.A.R.T input plugin (collects S.M.A.R.T statistics from disk drives)
 snmp - Build the snmp input plugin (reads values from network devices using SNMP)
 snmp_agent - Build an input plugin which implements an SNMP AgentX subagent that receives and handles queries from SNMP master agent and returns configured metrics