sci-mathematics/gmp-ecm: fix openmp check.
authorMichael Orlitzky <mjo@gentoo.org>
Sat, 29 Feb 2020 16:02:02 +0000 (11:02 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Sat, 29 Feb 2020 16:03:28 +0000 (11:03 -0500)
I screwed up the openmp check during translation from a manual
tc-has-openmp() check to tc-check-openmp(). Fixed now, sorry!

Closes: https://bugs.gentoo.org/711078
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild

index 98a97183de0fbb87dc96e44d3e7c957c518ac598..62d2aabe95ee931fa41366e293d5fe6930684f3b 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="https://gforge.inria.fr/frs/download.php/file/36224/${P}.tar.gz"
 LICENSE="GPL-3 LGPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="+custom-tune -openmp static-libs cpu_flags_x86_sse2"
+IUSE="+custom-tune openmp static-libs cpu_flags_x86_sse2"
 
 DEPEND="dev-libs/gmp:="
 RDEPEND="${DEPEND}"
@@ -23,7 +23,7 @@ REQUIRED_USE="x86-macos? ( !custom-tune )"
 S="${WORKDIR}/ecm-${PV}"
 
 pkg_pretend() {
-       tc-check-openmp
+       use openmp && tc-check-openmp
 }
 
 src_configure() {