sys-libs/glibc: introduce USE=+crypt
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 6 Nov 2019 20:10:23 +0000 (20:10 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 6 Nov 2019 20:10:36 +0000 (20:10 +0000)
Today libcrypt.so.1 is provided by glibc. Eventually glibc will
stop providing it in favoud of external providers like libcrypt.

USE=crypt exposes a knob to disable libcrypt.so.1 installation.
Use at your own risk. There currently is no replacement yet in
Gentoo.

Bug: https://bugs.gentoo.org/699422
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/glibc/glibc-2.30-r2.ebuild
sys-libs/glibc/metadata.xml

index 238a82906316733eb9d4d70a1f9d96c782f15878..c779a81334750d3e9cdff14476439686e46f829c 100644 (file)
@@ -34,7 +34,7 @@ PATCH_VER=3
 SRC_URI+=" https://dev.gentoo.org/~slyfox/distfiles/${P}-patches-${PATCH_VER}.tar.xz"
 SRC_URI+=" multilib? ( https://dev.gentoo.org/~dilfridge/distfiles/gcc-multilib-bootstrap-${GCC_BOOTSTRAP_VER}.tar.xz )"
 
-IUSE="audit caps cet compile-locales custom-cflags doc gd headers-only +multiarch multilib nscd profile selinux +ssp +static-libs suid systemtap test vanilla"
+IUSE="audit caps cet compile-locales +crypt custom-cflags doc gd headers-only +multiarch multilib nscd profile selinux +ssp +static-libs suid systemtap test vanilla"
 
 # Minimum kernel version that glibc requires
 MIN_KERN_VER="3.2.0"
@@ -941,6 +941,7 @@ glibc_do_configure() {
                --libexecdir='$(libdir)'/misc/glibc
                --with-bugurl=https://bugs.gentoo.org/
                --with-pkgversion="$(glibc_banner)"
+               $(use_enable crypt)
                $(use_multiarch || echo --disable-multi-arch)
                $(use_enable systemtap)
                $(use_enable nscd)
index 58d861be03051d0db99408e9782f15d03719e3e9..b00c5f56e586520edea1af4d2a9d0367ab2c78b1 100644 (file)
@@ -8,6 +8,7 @@
 <use>
  <flag name="cet">Enable Intel Control-flow Enforcement Technology (needs binutils 2.29 and gcc 8)</flag>
  <flag name="compile-locales">build *all* locales in src_install; this is generally meant for stage building only as it ignores /etc/locale.gen file and can be pretty slow</flag>
+ <flag name="crypt">build and install libcrypt and crypt.h</flag>
  <flag name="debug">When USE=hardened, allow fortify/stack violations to dump core (SIGABRT) and not kill self (SIGKILL)</flag>
  <flag name="gd">build memusage and memusagestat tools</flag>
  <flag name="multiarch">enable optimizations for multiple CPU architectures (detected at runtime)</flag>