dev-vcs/git-mantle: cram needed for tests (#631042 by toralf)
authorPacho Ramos <pacho@gentoo.org>
Wed, 20 Jun 2018 17:45:36 +0000 (19:45 +0200)
committerPacho Ramos <pacho@gentoo.org>
Wed, 20 Jun 2018 18:31:49 +0000 (20:31 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-vcs/git-mantle/git-mantle-0.6.ebuild

index ac478023a9cc1003fc4dbc93c69ec9e95942786f..08268e572163024c01fad03f09ca2a7a58b23c55 100644 (file)
@@ -1,9 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-
-inherit eutils
+EAPI=7
 
 DESCRIPTION="Generate an overview of changes on a branch"
 HOMEPAGE="https://github.com/roman-neuhauser/git-mantle"
@@ -12,15 +10,18 @@ SRC_URI="http://codex.sigpipe.cz/${PN}/${P}.tar.gz"
 
 LICENSE="MIT"
 SLOT="0"
+IUSE="test"
 
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
 
-DEPEND=""
+DEPEND="test? ( dev-util/cram )"
 RDEPEND="
        dev-vcs/git
        app-shells/zsh
 "
 
-src_install(){
+src_install() {
+       # Don't install in /usr/local
        emake PREFIX="${ED}/usr" install
+       einstalldocs
 }