dev-python/hiredis: Remove Py2
authorDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:12:48 +0000 (17:12 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:12:48 +0000 (17:12 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/hiredis/hiredis-0.2.0-r1.ebuild

index 1ac28728b1f20235fe60e3fac486ec76b2c0c9ae..98fe1101aaf643d3c161c88bef89ff2556be54a0 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python3_{5,6} )
 
 inherit distutils-r1
 
@@ -19,9 +19,3 @@ DEPEND=">=dev-libs/hiredis-0.13.1"
 RDEPEND="${DEPEND}"
 
 PATCHES=( "${FILESDIR}"/${P}-r1-system-libs.patch )
-
-python_compile() {
-       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
-
-       distutils-r1_python_compile
-}