sys-fs/snapraid-11.4: version bump; gcc 10 support.
authorPiotr Karbowski <slashbeast@gentoo.org>
Mon, 25 May 2020 20:47:27 +0000 (22:47 +0200)
committerPiotr Karbowski <slashbeast@gentoo.org>
Mon, 25 May 2020 20:49:02 +0000 (22:49 +0200)
Closes: https://bugs.gentoo.org/706392

Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
sys-fs/snapraid/Manifest
sys-fs/snapraid/snapraid-11.4.ebuild [new file with mode: 0644]

index 0d5dab687b5070dac6377cedd05b1b6295a90d70..1776bad2d71a0bc03a837c3daf7636edbc27abc5 100644 (file)
@@ -1,2 +1,3 @@
 DIST snapraid-11.2.tar.gz 735526 BLAKE2B d039c56c2fa4f0d2b333cb9eada2d59346e672c5196c0622c5536c5c3fe49b6df0ba742bcd467695fcbd46bb0ede06b1e54dc0c8088c275aeb4b1acd2f8e0f84 SHA512 975c0bb3e69e4feb2845c7d2971676beb59e3815070ee5fae09447925e74af5666dd51783fdadca096bd8bca43cfa19a88132d0999eb86a338915842a46a1834
 DIST snapraid-11.3.tar.gz 736549 BLAKE2B 67ad1e23630076b088167525e50f0ae2673201a9c02b25116d7d0ad9d2d8e34b17e240bd2fd90d39c6906842a6f321a2b76569d90c6ae24b40d1c6c335b8d6b4 SHA512 f0ed2bc1ab480b58220dac299ef95635747d5a8046bfcddf21b216d92d5cbfbf4299cb4130856a7fa5b808ba42662534b35a370193fe0a51791c994ed773a2ae
+DIST snapraid-11.4.tar.gz 742589 BLAKE2B 21c0976b6fcf792653fb0d2f223cd9b728e8850505aa78914c37fa2e3b5399df33b38fcbe870a567b1beb87ba1e2a37d63afc32ae08fb487d7b24fcffe5da8a4 SHA512 d9d5d48f6f996f2c1fbec2f84219b007ac28828d54e6b8614d05ab87f717b3498333ec950e861060c1278993f4971af2435cf8f268c0f1fb403c279d00a96b92
diff --git a/sys-fs/snapraid/snapraid-11.4.ebuild b/sys-fs/snapraid/snapraid-11.4.ebuild
new file mode 100644 (file)
index 0000000..d9c8f45
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="a backup program for disk array for home media centers"
+HOMEPAGE="http://snapraid.it/"
+SRC_URI="https://github.com/amadvance/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DOCS=( "AUTHORS" "HISTORY" "README" "TODO" "snapraid.conf.example" )
+
+src_prepare() {
+       default
+       eautoreconf
+}