dev-lang/ispc: remove old
authorChristoph Junghans <ottxor@gentoo.org>
Wed, 7 Oct 2015 15:56:11 +0000 (09:56 -0600)
committerChristoph Junghans <ottxor@gentoo.org>
Wed, 7 Oct 2015 15:56:11 +0000 (09:56 -0600)
Package-Manager: portage-2.2.20.1

dev-lang/ispc/Manifest
dev-lang/ispc/ispc-1.8.1.ebuild [deleted file]

index c2e4eb5e26166ee20b4a62ef91cb2f0401fda6cb..dc652abdfb6fd66a6d20cfec48a31d2333dc48da 100644 (file)
@@ -1,2 +1 @@
-DIST ispc-1.8.1.tar.gz 19222737 SHA256 adef83008bf9e2eb1947f0fbc38670d8bf801ddb36b1f22c4429a1c394e31f60 SHA512 515fd08d416f2f94444ae8771d1f5922b06c87fbebb552ab4003bf961307c1637eab35c46dcd9c356ce6ec159b441ff001edb4488c3dd6629496960a92bafe75 WHIRLPOOL ace2600866156e11a8cf90bb9e6c73a6cdcd1992d72761d9f3c64b16c6a34055410ac3172d6fb746a2a057704d6531e03f91bdbc7f7f480fa4884cbf91d75c3a
 DIST ispc-1.8.2.tar.gz 19259133 SHA256 d17ea68b7192d261a2830d6e00df656a73fbccd08a249433fcaf24a886902a9d SHA512 bb1f64afe41af138c386fb12a2a7f477f7bc8df2543191bbe7e5d7624e6b00dfec11ba422f6f396cd91af1c7b4cb5d2b3febf7902740d85c6d068de8ab94765a WHIRLPOOL 45ba7c52b3ada111f518b2a94d71d8c259040114ae84881c693f6e3491bd4b6897563eba4bccb6ae83a7cb90901bf1723bcbfeb9a124267ed235b1b8fdf61d69
diff --git a/dev-lang/ispc/ispc-1.8.1.ebuild b/dev-lang/ispc/ispc-1.8.1.ebuild
deleted file mode 100644 (file)
index 0d283bb..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit toolchain-funcs python-any-r1
-
-DESCRIPTION="Intel SPMD Program Compiler"
-HOMEPAGE="https://ispc.github.com/"
-
-if [[ ${PV} = *9999 ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="git://github.com/ispc/ispc.git"
-       KEYWORDS=""
-else
-       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="BSD BSD-2 UoI-NCSA"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
-       >=sys-devel/clang-3.0
-       >=sys-devel/llvm-3.0
-       "
-DEPEND="
-       ${RDEPEND}
-       ${PYTHON_DEPS}
-       sys-devel/bison
-       sys-devel/flex
-       "
-
-src_compile() {
-       sed -i '/^\t@/s/@//' Makefile || die #make all slient commands ("@") verbose
-       emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
-}
-
-src_install() {
-       dobin ispc
-       dodoc README.rst
-
-       if use examples; then
-               insinto "/usr/share/doc/${PF}/examples"
-               docompress -x "/usr/share/doc/${PF}/examples"
-               doins -r examples/*
-       fi
-}