dev-python/jellyfish: Disable in-source builds
authorMichał Górny <mgorny@gentoo.org>
Mon, 8 Jul 2019 08:09:13 +0000 (10:09 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 8 Jul 2019 08:19:52 +0000 (10:19 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/jellyfish/jellyfish-0.7.2.ebuild

index d8d3b2e32dd4da8fa5797f94493ed71837fe3d5e..8b4b1810513b3a0f5042079db57ee07df012a76a 100644 (file)
@@ -4,7 +4,6 @@
 EAPI=7
 
 PYTHON_COMPAT=( python3_{5,6,7} )
-DISTUTILS_IN_SOURCE_BUILD=1
 inherit distutils-r1
 
 DESCRIPTION="Python module for doing approximate and phonetic matching of strings"
@@ -25,11 +24,6 @@ DEPEND="
        )
 "
 
-python_compile() {
-       esetup.py build_ext --inplace
-       esetup.py build
-}
-
 python_compile_all() {
        if use doc; then
                esetup.py build_sphinx
@@ -38,5 +32,7 @@ python_compile_all() {
 }
 
 python_test() {
-       py.test jellyfish/test.py || die "tests failed with ${EPYTHON}"
+       cp -r testdata "${BUILD_DIR}" || die
+       cd "${BUILD_DIR}" || die
+       pytest -vv lib/jellyfish/test.py || die "tests failed with ${EPYTHON}"
 }