dev-db/pgrouting: Bump to 2.6.2
authorAaron W. Swenson <titanofold@gentoo.org>
Fri, 21 Jun 2019 10:05:40 +0000 (06:05 -0400)
committerAaron W. Swenson <titanofold@gentoo.org>
Fri, 21 Jun 2019 10:07:55 +0000 (06:07 -0400)
Fixes doc installation.

Bug: https://bugs.gentoo.org/625778
Package-Manager: Portage-2.3.62, Repoman-2.3.11
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
dev-db/pgrouting/Manifest
dev-db/pgrouting/pgrouting-2.6.2.ebuild [new file with mode: 0644]

index 40ae7848e252a01eab330f17709b5d78fcdcc33d..8c026319d9ce764b37d59b5aeed16f45df8cec73 100644 (file)
@@ -1 +1,2 @@
 DIST pgrouting-2.5.2.tar.gz 7221479 BLAKE2B afbf29b7cbd52df526203198fb76d9e9e37e88a4b92d2139975238a14fe5a30c8102449d157e391913e690129a1ca8ac718763d9242193cac4080bc7347e1553 SHA512 9d9d9ebbcbc003f62bf1f0d548363e756012cdce55a9c3ef56ae9a5a510f25337898becf42f3e04bf10e8d3672ebf698def03833bba33410b65e0d2bdd42aecd
+DIST pgrouting-2.6.2.tar.gz 6065517 BLAKE2B e27e28cf988040de1e894a857e3d210bc7676271f69d898afc2d6116d5b88d87404723b2cb1283ef77b4449b4aa62a03e2dbcd489ac641a4721a596d29f8fecd SHA512 6e37f66e631d0cc87e135be7d095822aae21656bb56b3d18afa5bececaad8cee6324d37e8e152bbf69e3374ded1f10aa4b9a4c52b873e3a4c43e73cd877fddcb
diff --git a/dev-db/pgrouting/pgrouting-2.6.2.ebuild b/dev-db/pgrouting/pgrouting-2.6.2.ebuild
new file mode 100644 (file)
index 0000000..7690a22
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+POSTGRES_COMPAT=( 9.{4..6} 10 11 )
+POSTGRES_USEDEP="server"
+
+inherit  postgres cmake-utils
+
+DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing functionality."
+HOMEPAGE="http://pgrouting.org/"
+LICENSE="GPL-2 MIT Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="https://github.com/pgRouting/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="doc pdf html"
+
+REQUIRED_USE="html? ( doc ) pdf? ( doc )"
+
+RDEPEND="${POSTGRES_DEP}
+       >=dev-db/postgis-2.0
+       dev-libs/boost
+       sci-mathematics/cgal
+"
+
+DEPEND="
+       doc? ( >=dev-python/sphinx-1.2 )
+       pdf? ( >=dev-python/sphinx-1.2[latex] )
+"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+pkg_setup() {
+       postgres_pkg_setup
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DBUILD_HTML=$(usex html)
+               -DBUILD_LATEX=$(usex pdf)
+               -DBUILD_MAN=ON
+               -DWITH_DOC=$(usex doc)
+       )
+
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       local make_opts
+       use doc && make_opts="all doc"
+       cmake-utils_src_make ${make_opts}
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       doman "${BUILD_DIR}"/doc/man/en/pgrouting.7
+
+       use html && dodoc -r "${BUILD_DIR}"/doc/html
+       use pdf && dodoc "${BUILD_DIR}"/doc/latex/en/*.pdf
+}