acct-user/puppetdb: add puppetdb user
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 19 Feb 2020 22:23:55 +0000 (16:23 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 19 Feb 2020 22:24:14 +0000 (16:24 -0600)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
RepoMan-Options: --force
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
acct-user/puppetdb/metadata.xml [new file with mode: 0644]
acct-user/puppetdb/puppetdb-0.ebuild [new file with mode: 0644]

diff --git a/acct-user/puppetdb/metadata.xml b/acct-user/puppetdb/metadata.xml
new file mode 100644 (file)
index 0000000..976e9e9
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <longdescription lang="en">
+                       puppetdb user
+       </longdescription>
+</pkgmetadata>
diff --git a/acct-user/puppetdb/puppetdb-0.ebuild b/acct-user/puppetdb/puppetdb-0.ebuild
new file mode 100644 (file)
index 0000000..7f70113
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="User for the puppetdb service"
+ACCT_USER_ID=456
+ACCT_USER_HOME=/opt/puppetlabs/server/data/puppetserver
+ACCT_USER_HOME_PERMS=0770
+ACCT_USER_GROUPS=( puppetdb )
+
+acct-user_add_deps