net-wireless/cpyrit-cuda: fix lexicographical version compare
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 19 Apr 2020 15:00:17 +0000 (16:00 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 19 Apr 2020 15:00:17 +0000 (16:00 +0100)
Closes: https://bugs.gentoo.org/705270
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
net-wireless/cpyrit-cuda/cpyrit-cuda-0.5.0.ebuild

index 3b338589951f40e06287cc9d2b1e867db6ba9753..3c8d5c041e81c3242e6630aee938923606c4bcbf 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
 PYTHON_COMPAT=( python2_7 )
 DISTUTILS_SINGLE_IMPL=1
 
-inherit toolchain-funcs distutils-r1
+inherit toolchain-funcs distutils-r1 eapi7-ver
 
 DESCRIPTION="A sub-package that adds CUDA-capability to Pyrit"
 HOMEPAGE="https://github.com/JPaulMora/Pyrit"
@@ -26,8 +26,8 @@ PDEPEND="~net-wireless/pyrit-${PV}"
 S="${WORKDIR}/Pyrit-${PV}/modules/cpyrit_cuda"
 
 pkg_pretend() {
-       if tc-is-gcc && [[ $(gcc-version) > 4.8 ]]; then
-               die "gcc 4.9 and up are not supported"
+       if tc-is-gcc && ver_test $(gcc-version) -ge 4.8; then
+               die "gcc 4.8 and up are not supported"
        fi
 }