dev-python/pygpgme: add python3_8
authorAndrey Grozin <grozin@gentoo.org>
Thu, 23 Apr 2020 05:48:18 +0000 (12:48 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Thu, 23 Apr 2020 05:48:18 +0000 (12:48 +0700)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-python/pygpgme/pygpgme-0.3-r2.ebuild [new file with mode: 0644]

diff --git a/dev-python/pygpgme/pygpgme-0.3-r2.ebuild b/dev-python/pygpgme/pygpgme-0.3-r2.ebuild
new file mode 100644 (file)
index 0000000..feeddfd
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="A Python wrapper for the GPGME library"
+HOMEPAGE="https://launchpad.net/pygpgme"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="app-crypt/gpgme"
+RDEPEND="${DEPEND}"
+
+python_configure_all() {
+       append-cflags $(gpgme-config --cflags)
+}